3

... Cannot mix incompatible Qt library (version 0x40804) with this library (version 0x40801) Aborted core dumped

The Problem occurs with 64-Bit Ubuntu 13.04 when starting k3b, ebook-viewer ..., gnome-classic (no effects).

Sometimes the border of all open windows and terminals disappear and I have to reboot.

I didn't find out which libraries are conflicting ...

Kind Regards Justus Gadient

xxx@yyy:~/Desktop$ echo $LD_LIBRARY_PATH 
/usr/lib:/usr/local/lib::/opt/AMDAPP/lib/x86_64:/opt/intel/opencl/lib64:/opt/intel/opencl/libmic

open("x86_64/libQtXml.so.4", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
read(3, Cannot mix incompatible Qt library (version 0x40804) with this library (version 0x40801)
stat("/usr/local/DigiaQtCommercialSDK/Desktop/481/gcc-64/plugins", 0x7fff8cf68e80) = -1 ENOENT (No such file or directory)

ldd
linux-vdso.so.1 =>  (0x00007fffa83fe000)
libk3bdevice.so.6 => /usr/lib/libk3bdevice.so.6 (0x00007f30ea2ac000)
libk3blib.so.6 => /usr/lib/libk3blib.so.6 (0x00007f30e9efb000)
libkcddb.so.4 => /usr/lib/libkcddb.so.4 (0x00007f30e9c9a000)
libkfile.so.4 => /usr/lib/libkfile.so.4 (0x00007f30e99f5000)
libkio.so.5 => /usr/lib/libkio.so.5 (0x00007f30e9558000)
libknotifyconfig.so.4 => /usr/lib/libknotifyconfig.so.4 (0x00007f30e9345000)
libkde3support.so.4 => /usr/lib/libkde3support.so.4 (0x00007f30e9050000)
libsolid.so.4 => /usr/lib/libsolid.so.4 (0x00007f30e8d64000)
libQtWebKit.so.4 => /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4 (0x00007f30e6a16000)
libkcmutils.so.4 => /usr/lib/libkcmutils.so.4 (0x00007f30e67d8000)
libQt3Support.so.4 => /usr/lib/x86_64-linux-gnu/libQt3Support.so.4 (0x00007f30e6306000)
libQtXml.so.4 => /usr/lib/x86_64-linux-gnu/libQtXml.so.4 (0x00007f30e60c3000)
libkdeui.so.5 => /usr/lib/libkdeui.so.5 (0x00007f30e5a7f000)
libkdecore.so.5 => /usr/lib/libkdecore.so.5 (0x00007f30e55bf000)
libQtCore.so.4 => /opt/intel/opencl/lib64/libQtCore.so.4 (0x00007f30e50ca000)
libQtDBus.so.4 => /usr/lib/x86_64-linux-gnu/libQtDBus.so.4 (0x00007f30e4e4f000)
libQtGui.so.4 => /opt/intel/opencl/lib64/libQtGui.so.4 (0x00007f30e40e7000)
libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f30e3de3000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f30e3a1a000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f30e3715000)
libsamplerate.so.0 => /usr/lib/x86_64-linux-gnu/libsamplerate.so.0 (0x00007f30e33a8000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f30e31a4000)
libdvdread.so.4 => /usr/lib/x86_64-linux-gnu/libdvdread.so.4 (0x00007f30e2f87000)
libmusicbrainz5.so.0 => /usr/lib/x86_64-linux-gnu/libmusicbrainz5.so.0 (0x00007f30e2cfe000)
libQtNetwork.so.4 => /usr/lib/x86_64-linux-gnu/libQtNetwork.so.4 (0x00007f30e29bf000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f30e27a9000)
libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f30e259e000)
libnepomuk.so.4 => /usr/lib/libnepomuk.so.4 (0x00007f30e22ce000)
libQtSvg.so.4 => /usr/lib/x86_64-linux-gnu/libQtSvg.so.4 (0x00007f30e2078000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007f30e1d3d000)
libstreamanalyzer.so.0 => /usr/lib/libstreamanalyzer.so.0 (0x00007f30e1ac5000)
libacl.so.1 => /lib/x86_64-linux-gnu/libacl.so.1 (0x00007f30e18bd000)
libattr.so.1 => /lib/x86_64-linux-gnu/libattr.so.1 (0x00007f30e16b7000)
libphonon.so.4 => /usr/lib/x86_64-linux-gnu/libphonon.so.4 (0x00007f30e1449000)
libkparts.so.4 => /usr/lib/libkparts.so.4 (0x00007f30e11f5000)
libkpty.so.4 => /usr/lib/libkpty.so.4 (0x00007f30e0feb000)
libudev.so.1 => /lib/x86_64-linux-gnu/libudev.so.1 (0x00007f30e0dda000)
libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f30e0bc2000)
libjpeg.so.8 => /usr/lib/x86_64-linux-gnu/libjpeg.so.8 (0x00007f30e0971000)
libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007f30e074b000)
libxslt.so.1 => /usr/lib/x86_64-linux-gnu/libxslt.so.1 (0x00007f30e050e000)
libgstapp-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstapp-0.10.so.0 (0x00007f30e0302000)
libgstinterfaces-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstinterfaces-0.10.so.0 (0x00007f30e00f0000)
libgstpbutils-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstpbutils-0.10.so.0 (0x00007f30dfecb000)
libgstvideo-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstvideo-0.10.so.0 (0x00007f30dfcaf000)
libgstbase-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstbase-0.10.so.0 (0x00007f30dfa5b000)
libgstreamer-0.10.so.0 => /usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0 (0x00007f30df774000)
libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f30df525000)
libxml2.so.2 => /usr/lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f30df1c2000)
libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f30deec5000)
libsqlite3.so.0 => /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f30dec19000)
libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f30de9df000)
libQtOpenGL.so.4 => /usr/lib/x86_64-linux-gnu/libQtOpenGL.so.4 (0x00007f30de6e0000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x00007f30de501000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f30de2e4000)
libQtSql.so.4 => /usr/lib/x86_64-linux-gnu/libQtSql.so.4 (0x00007f30de0a4000)
libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007f30dde9c000)
libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007f30ddc7f000)
libattica.so.0.4 => /usr/lib/x86_64-linux-gnu/libattica.so.0.4 (0x00007f30dd9c7000)
libdbusmenu-qt.so.2 => /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2 (0x00007f30dd794000)
libXfixes.so.3 => /usr/lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f30dd58d000)
libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f30dd37d000)
liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f30dd15b000)
libdlrestrictions.so.1 => /usr/lib/libdlrestrictions.so.1 (0x00007f30dcf56000)
libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f30dcd54000)
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f30dcb4c000)
/lib64/ld-linux-x86-64.so.2 (0x00007f30ea4e3000)
libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f30dc907000)
libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f30dc66a000)
libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007f30dc457000)
libneon-gnutls.so.27 => /usr/lib/libneon-gnutls.so.27 (0x00007f30dc230000)
libsoprano.so.4 => /usr/lib/libsoprano.so.4 (0x00007f30dbf49000)
libsopranoclient.so.1 => /usr/lib/libsopranoclient.so.1 (0x00007f30dbcfb000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f30dbadd000)
libstreams.so.0 => /usr/lib/libstreams.so.0 (0x00007f30db8a6000)
libpulse.so.0 => /usr/lib/x86_64-linux-gnu/libpulse.so.0 (0x00007f30db65e000)
libpulse-mainloop-glib.so.0 => /usr/lib/x86_64-linux-gnu/libpulse-mainloop-glib.so.0 (0x00007f30db459000)
libnepomukutils.so.4 => /usr/lib/libnepomukutils.so.4 (0x00007f30db21f000)
libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007f30db01c000)
libutempter.so.0 => /usr/lib/libutempter.so.0 (0x00007f30dae19000)
liborc-0.4.so.0 => /usr/lib/x86_64-linux-gnu/liborc-0.4.so.0 (0x00007f30dab9a000)
libgmodule-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f30da996000)
libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007f30da78d000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f30da54e000)
libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f30da325000)
libatiuki.so.1 => /usr/lib/libatiuki.so.1 (0x00007f30da207000)
libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f30da002000)
libgnutls.so.26 => /usr/lib/x86_64-linux-gnu/libgnutls.so.26 (0x00007f30d9d45000)
libgssapi_krb5.so.2 => /usr/lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007f30d9b07000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007f30d9902000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f30d96fc000)
libjson.so.0 => /lib/x86_64-linux-gnu/libjson.so.0 (0x00007f30d94f3000)
libpulsecommon-3.0.so => /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-3.0.so (0x00007f30d928f000)
libnepomukquery.so.4 => /usr/lib/libnepomukquery.so.4 (0x00007f30d9049000)
libgcrypt.so.11 => /lib/x86_64-linux-gnu/libgcrypt.so.11 (0x00007f30d8dca000)
libtasn1.so.3 => /usr/lib/x86_64-linux-gnu/libtasn1.so.3 (0x00007f30d8bb9000)
libp11-kit.so.0 => /usr/lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007f30d89a5000)
libkrb5.so.3 => /usr/lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007f30d86d6000)
libk5crypto.so.3 => /usr/lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007f30d84ad000)
libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007f30d82a9000)
libkrb5support.so.0 => /usr/lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007f30d80a0000)
libwrap.so.0 => /lib/x86_64-linux-gnu/libwrap.so.0 (0x00007f30d7e96000)
libsndfile.so.1 => /usr/lib/x86_64-linux-gnu/libsndfile.so.1 (0x00007f30d7c30000)
libasyncns.so.0 => /usr/lib/x86_64-linux-gnu/libasyncns.so.0 (0x00007f30d7a29000)
libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f30d7825000)
libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007f30d7620000)
libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f30d7406000)
libnsl.so.1 => /lib/x86_64-linux-gnu/libnsl.so.1 (0x00007f30d71ec000)
libFLAC.so.8 => /usr/lib/x86_64-linux-gnu/libFLAC.so.8 (0x00007f30d6f9f000)
libvorbisenc.so.2 => /usr/lib/x86_64-linux-gnu/libvorbisenc.so.2 (0x00007f30d6ad0000)
libvorbis.so.0 => /usr/lib/x86_64-linux-gnu/libvorbis.so.0 (0x00007f30d68a3000)
libogg.so.0 => /usr/lib/x86_64-linux-gnu/libogg.so.0 (0x00007f30d669b000)
  • "Cannot mix incompatible" says everything. You can only mix compatible ingredients, no? – Braiam Nov 3 '13 at 12:15
  • Meanwhile I upgraded to 13.10 but the Problem still exists on my new Ultrabook. (No longer on my old Desktop with similar 64-Bit configuration, since yesterday some qt... upgrades dropped in, still don't know whether this is the cause) Unfortunately I urgently need an offline epub reader on my Ultrabook, so I use Adobe digital edition in a VirtualBox Windows for the moment, sorry for that ;-) Kind Regards Justus Gadient – Justus Gadient Nov 17 '13 at 11:01
1

Finally I found the cause: Once upon a time I created a Timetracker with qtcreator. Still compiles and runs fine in the IDE but the binary on the command line does not run:

xxx@xxx:... qt/TimeTracker/QTTimeTracker$ ./QTTimeTracker Cannot mix incompatible Qt library (version 0x40804) with this library (version 0x40801) Aborted (core dumped)

xxx@xxx:... qt/TimeTracker/QTTimeTracker$ ldd QTTimeTracker ...

libQtGui.so.4 => /opt/intel/opencl/lib64/libQtGui.so.4 (0x00007f742f370000)
libQtCore.so.4 => /opt/intel/opencl/lib64/libQtCore.so.4 (0x00007f742ee7b000)
                      =====>häääh

...

Obviously the HD4000 opencl driver installs QTlibs?? Moving them to "/opt/intel/opencl/lib64/whatdotheqtlibshere/" seems to solve my problems (QTTimetracker and fbreader do not crash any more, heissa)

  • Exactly the problem I had! Thanks a bunch for posting this. – Greg Kramida Feb 10 '14 at 14:24
  • On Antergos a removal of qt5-styleplugins (sudo pacman -R qt5-styleplugins) solved this issue. – holzkohlengrill Jun 6 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.