0

I am going crazy here. One day everything was working fine. I turned pc off and went to sleep. Next day turn pc on and cannot access internet (from any browser).

The situation is: I cannot open any webpage from browser (tried Firefox and Epiphany) and cannot receive emails in thunderbird. BUT if I run firefox from console as sudo, I can use it as usual. I can access Skype and pretty much any other network stuff (like installing software with apt-get etc.), also if I use Astrill VPN software I can access webpages even running without sudo.

I haven't install any software or anything like that for several days = I have not a clue what could cause this. Just by the way, other Win PC in our home has no issue.

Here is what I have tried to fix this:

  • I have tried to restart my pc, router, modem - multiple times
  • I have tried to change permissions to my firefox profile
  • I have tried to completely re-install firefox and start with blank profile, thus no addons
  • I have tried to change /etc/resolv.conf to an IP of my router (it was 127.0.1.1)
  • I have tried to change my hostname (from tomino-NB to tominoNB)

I think I might try even more stuff. None of it works.

Can someone please try to help me. Thank you

UPDATE 1:

I have tried this: Removing resolv.conf - Didn't help Also "ping" and "dig" commands cannot resolve host

UPDATE 2:

I have tried to edit nameservers in resolv.conf but still no effect. I can ping router as well as I can ping outside IP. So definitely just some DNS issue. Is it possible that something is rewriting path to resolv.conf and using different file?

UPDATE 3:

I have just restarted PC and everything works now... resolv.conf went back to nameserver 127.0.1.1 . I have no clue what happened that it works again...

1

This is not a Firefox or Ubuntu specific problem. To me it seems to be a DNS problem. The information you provide assumes it is a software problem (which I think it is not). Since you use the abbreviation NB I guess you have a notebook and you have traveled between different networks... this can cause a change in the DNS resolving information. But to be sure, can you ping your router and/or an outside IP address?

BTW, resolv.conf should contain your DNS information, not your local router (only if it runs a DNS caching daemon) or localhost:

nameserver 8.8.8.8
nameserver 8.8.4.4

Note: you can add these entries, but they are not always optimal as these are provided by Google. Use the one provided by your ISP if possible.

Could you try opening a page by using the IP address: e.g. 173.194.37.65 for one of Google. And if not, can you ping it at least. A traceroute would be better.

Note: User was able to connect to outside webpages using the IP address, so confirmed it was a DNS problem. Eventually adding the entries to DNS and a restart of the notebook made it work. I suspect he messed up his networkstack since he also used Astrill. A problem I have also encountered on Fedora many times (ld_preload maybe the cause?). At least it works for him ATM.

2
  • I have tried different nameservers, still nothing. I updated the question check it out
    – Tomas
    Nov 3 '13 at 3:03
  • User contacted me by email; problem seems to be resolved.
    – gbraad
    Nov 3 '13 at 6:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.