3

I'm using Document Viewer (Evince) 3.4.0 on Ubuntu 12.04, but would like to use version 3.10, since it has a new feature which is very useful in my work. I've used the link provided here https://apps.ubuntu.com/cat/applications/saucy/evince/ but it just shows me that Evince is already installed (the older version).

Can somebody please help me?

  • You wrongly mentioned the link.Ubuntu 12.04 is precise not saucy. – Avinash Raj Nov 3 '13 at 0:28
  • 1
    @AvinashRaj Read the quesiton. The OP wants to install the version of Evince from Saucy (v3.10 which was linked) into Precise. – kiri Nov 3 '13 at 0:39
1

To avoid a lot of black magic shuffeling repositories for just one packet is a bit over the top so I tried another way to install it.

1) apt-get remove evince remove the current version

2) downloaded the evince from http://packages.ubuntu.com/nl/saucy/evince

3) apt-get install gdebi

4) use gdebi to install the evince that just downloaded

5) against my expectations I landed in dependency hell!

A lot of times this method works okay but this time I had over 50(!) cumulative dependencies.
Added to this: a few libs were very core bound to the system so the chance of breaking the system was extreme.

Conclusion: This was not the way to install evince 3.10 in Ubuntu Precise.

| improve this answer | |
  • He was using precise,not saucy.Try to update the link. – Avinash Raj Nov 3 '13 at 0:26
  • Read again, Avinash. He has Ubuntu Precise installed and using evince from Ubuntu Precise, but he wants to run the evince from Ubuntu Saucy on Ubuntu Precise. – thom Nov 3 '13 at 0:34
  • 1
    Evince 3.10 depends on libglib2.0-0 (>= 2.37.3). Precise has 2.32.1-0ubuntu2, etc. Step 5 requires a lot more than you are indicating and may break other things. – chaskes Nov 3 '13 at 0:34
  • A few dependencies are solvable...if the number of dependencies are getting overwhelming, it is easy to reverse the steps (I have done that before). How many dependencies do you estimate he would have to solve ? Your answer might save him some work. – thom Nov 3 '13 at 0:39
  • @Thom, with respect, this isn't my answer, it's yours. I'm just trying to help you improve it. :) You may want to look into the dependency situation in more detail and add it to your answer. – chaskes Nov 3 '13 at 0:49
1

There is a way but you won't like it. Jhbuild can create a local GNOME app installation in a folder of your choice with all necessary dependencies and libraries. It won't affect your system because it bypasses the package manager and only downloads and installs files to the folder you chose.

However:

  • You will have to fetch about 1GB of GNOME dependencies

  • You will have to compile them (which depending on your system might take quite long)

  • The end product might not integrate that well with your system. At least from my experience it didn't, with icons not being displayed, no proper Zeitgeist integration and issues with settings, etc.

All things considered you will definitely have to ask yourself if it's actually worth the effort to you. Hopefully click packages will solve issues like these in the future.

| improve this answer | |
  • It does seem a long way to go. I guess I'm going to have to install Ubuntu 13.10 side by side with 12.04 just to use Evince 3.10. It might sound silly, but it might be best. Thanks. – João Pedro Tapada Nov 5 '13 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.