7

Ubuntu 13.10.

The problem is: the internal speakers don't work. I have no problem when I'm using the headphones. There is no hardware issue since in windows 8 everything works perfectly(external subwoofer included).

I tried to modify /etc/modprobe.d/alsa-base.conf but I can't find the correct model to put into:

 options snd-hda-intel model=

The file HD-Audio-Models.txt doesn't contain the model for ALC668. Then I found out that this method may not be so useful because the information in https://help.ubuntu.com/community/HdaIntelSoundHowto is outdated.

I also played with alsamixer -V all command but I had no success.

Some info:

:~sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC668 Analog [ALC668 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
:~$ sudo lspci -v | grep -A7 -i "audio"
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
    Subsystem: Intel Corporation Device 2010
    Flags: bus master, fast devsel, latency 0, IRQ 52
    Memory at f7a14000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit-
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Kernel driver in use: snd_hda_intel
--
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
    Subsystem: ASUSTeK Computer Inc. Device 11cd
    Flags: bus master, fast devsel, latency 0, IRQ 53
    Memory at f7a10000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: [50] Power Management version 2
    Capabilities: [60] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [70] Express Root Complex Integrated Endpoint, MSI 00
    Capabilities: [100] Virtual Channel

PS info

:~$ amixer -c 0
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',1
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'IEC958',2
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]

:~$ pacmd dump-volumes
Welcome to PulseAudio! Use "help" for usage information.
>>> Sink 0: reference = 0:  76% 1:  76%, real = 0:  76% 1:  76%, soft = 0: 100% 1: 100%, current_hw = 0:  76% 1:  76%, save = yes
    Input 8: volume = 0: 100% 1: 100%, reference_ratio = 0: 100% 1: 100%, real_ratio = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, volume_factor = 0: 100% 1: 100%, volume_factor_sink = 0: 100% 1: 100%, save = no
Source 0: reference = 0: 100% 1: 100%, real = 0: 100% 1: 100%, soft = 0: 100% 1: 100%, current_hw = 0: 100% 1: 100%, save = no
Source 1: reference = 0:  16% 1:  16%, real = 0:  16% 1:  16%, soft = 0: 100% 1: 100%, current_hw = 0:  16% 1:  16%, save = yes

:~$ amixer -c 1
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 78 [90%] [-6.75dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 253 [99%] [0.40dB]
  Front Right: Playback 253 [99%] [0.40dB]
Simple mixer control 'Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [30.00dB]
  Front Right: 3 [100%] [30.00dB]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 63
  Front Left: Capture 0 [0%] [-17.25dB] [on]
  Front Right: Capture 0 [0%] [-17.25dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'

  • I tried to follow this help.ubuntu.com/community/HdaIntelSoundHowto – artBCode Nov 2 '13 at 20:43
  • Thank for you time. The problem is: the internal speakers don't work. I have no problem when I'm using the headphones. There is no hardware issue since in windows 8 all work perfectly(external subwoofer included). – artBCode Nov 2 '13 at 21:46
  • Have you check that the volumes are not muted? What amixer -c 0, pacmd dump-volumes says? Edit your question and add the previous comment too plus the output of those commands? – Braiam Nov 2 '13 at 21:50
  • I've just updated the original post. – artBCode Nov 2 '13 at 22:05
  • You sure the information of amixer -c 0 isn't cut off? Try adding amixer -c 1 too. – Braiam Nov 2 '13 at 22:14
2

I've got the same laptop Asus N550JV and faced the same issue as yours.

While booting, I chose 3.11.0.12-generic kernel from the "advanced options for Ubuntu" and sound started to work just fine.

I rebooted and used the newer standard kernel and now it's surprisingly working.

Try that.. hope it will help .

  • 2
    In addition, i have noticed that sound doesn't work if you boot into ubuntu after windows 8. So you have to reboot again and sound appears. – Yauhen Vasileusky Dec 13 '13 at 21:19
  • 2
    A note on what Yauhen said: I found that if rebooting from windows and the sound stopped, I could just suspend and resume to make it work again (full reboot not necessary). Also see bugzilla.kernel.org/show_bug.cgi?id=67711 – dustyneuron Jan 21 '14 at 23:08
  • I can confirm everything of the above. Maybe we need the 3.12 kernel branch, in the end. – Andrea Boscolo Feb 13 '14 at 16:18
1

Same happened to me. Sound only worked with an updated kernel (3.11.0.12). I just waited for the official Ubuntu update. However, after upgrading it again to 3.11.0.14 or .15, speakers stopped working. After doing what Bassam suggests, I got my speakers sound back.

For those of you trying to enable the subwoofer output, I recommend you to follow these guides:

They worked fine for me.

0

I've got the same laptop, and same problem. I installed the new kernel 3.12 and now my speakers are working. Im running xubuntu 13.10.

The following link gives and explanation on how to upgrade kernel, and a warning that this may cause other problems:

"We have to warn you from the get-go. Canonical does not recommend updating your Linux kernel to other versions than the ones provided on official channels. This is not a totally safe procedure and you might have problems afterwards, even system failures. On the other hand, you might get better performance from your system."

http://news.softpedia.com/news/How-to-Install-Linux-Kerrnel-3-12-in-Ubuntu-13-10-397013.shtml

  • I've tried this solution on asus n750jv (the same soundcard). The sound appeared but: 1)External subwoofer doesn't work. 2)The only working configuration is 2.0 3)In skype: if i set in system setting analog output as default i have sound, but microfon doesn't work. If i set analog input as default audio profile, microfon works, but there is no sound from speakers. – Yauhen Vasileusky Nov 11 '13 at 16:59
  • When I upgrade to the 3.12 kernel, I get a kernel panic: not syncing, no init error on boot. Had to boot to the older kernel to get back. – edtechdev Nov 17 '13 at 7:43

protected by Community Mar 2 '14 at 10:46

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.