6

I have an Archos 605 media player that seems to have become corrupted, so I'm trying to run fsck on it. It mounts as a FAT32 hard drive, so I ran

sudo dosfsck -a

and this is what I got:

dosfsck 3.0.7, 24 Dec 2009, FAT32, LFN There are differences between boot sector and its backup. Differences: (offset:original/backup) 65:03/00
Not automatically fixing this. Unable to create unique name

I suspect this means I'm screwed, but I'd appreciate any additional insight from someone who knows more about dosfsck than I do.

4

it sounds like the partition table is screwed up.

Fortunately there is a good linux tool to get it back working
http://en.wikipedia.org/wiki/TestDisk

sudo apt-get install testdisk

the wiki contains a good guide for exactly your problem (recover fat32 partition)
http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step

|improve this answer|||||
0

Another solution I use:

fsck.vfat -r /dev/sdXn

I asked for use partition table backup (yes) and fix some clusters issue (I select no).

After that I rerun and fix Free cluster summary wrong. Next I run:

sudo dosfsck -w -l -a -v  /dev/sdXn

and it report that all ok!

See blog http://tech-vaults.blogspot.com/2011/10/fsckvfat-unable-to-create-unique-name.html

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.