12

I have a Macbok Pro 13" and I'm using virtualbox to run ubuntu 12.04. My problem is I can't resize ubuntu for occupy the 13" of my screen when I use full-screen mode. Ubuntu only allows me to use two screen size options, 1024x768 or 800x600. The 800x600 option is too small, and cuts the screen in a smaller size with black edges.With the 1024x768 option, i only have black edges on the left and on the right. Is there any option for extending the image at the whole screen?

1
  • Did you install Guest Additions?
    – Mitch
    Commented Nov 2, 2013 at 12:34

5 Answers 5

16

When logged into the virtual machine:

  1. In VirtualBox UI, use menu Devices | Insert Guest Additions CD image...
  2. They will ask to download the .iso CD image.
  3. Select Yes, and once the download completes it it will ask you if you want to install the same.
  4. Go through the steps on the installer (mostly click Yes or Next)
  5. Restart the Virtual machine, if needed.

Enjoy!

1
  • 6
    I have done the same for CentOS in the Mac OS host. I can Install Guest additions but this doesn't change anything. Do you have any suggestion?
    – Arefe
    Commented Jul 11, 2018 at 15:01
4

Installing Guest additions works perfectly fine. Just in case if someone still facing the screen size issue as i was facing, you can follow the below steps :

sudo apt-get update // just to get all system dependencies

sudo apt-get install virtualbox-guest-additions-iso // to get guest additions

and the final one
sudo apt-get install virtualbox-guest-dkms.

Please let me know if anyone still faces the issue.

1
  • 2
    I did the same, but does not work. these steps worked for me for windows and Linux host OS, but someone I can't get it working on OS X host machine. I am using 13' map
    – chandank
    Commented Aug 21, 2016 at 17:49
4

There's one extra step I needed in order to get Guest Additions to work on MacOS Mojave. With the VM shut down, go to VM Settings -> Display -> Screen. Enable 3D acceleration and max out the RAM (128MB works for me but virtualbox.org recommends 256MB). You can then restart the VM with your newly full-screened situation.

This solution also fixed my problem of having a discrepancy between where my mouse was on the screen and where it was actively pointing. This made it hard to press buttons, etc.

SOURCE: https://forums.virtualbox.org/viewtopic.php?f=3&t=91086

1
  • Worked with a MBP 13" running macOS Big Sur, thanks :)
    – FET
    Commented Mar 19, 2021 at 16:26
2

For Ubuntu 20.04 in a MacBookPro 13"

  1. In VirtualBox > Settings > Display Video Memory = 64MB VM Settings panel screenshot

  2. In Ubuntu20.04 [Virtual Machine]

    Settings > Displays > Resolution = 2560x1600

    Settings > Displays > Scale = 200%

    Ubuntu20.04 settings panel screenshot

Not FULL SCREEN, but it works for me

-1

you need to install the guest additions in order to access the fullscreen mode

1
  • 2
    Care to explain how this can be installed?
    – Braiam
    Commented Nov 2, 2013 at 13:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .