5

I have been experiencing this super annoying bug with fonts in LibreOffice. Please see below screenshot. The spaces between letters are just messed, no matter what font or level of zoom I choose. When I change the zoom level, the spacing is actually changing but still looks very ugly.

I have a pretty much default instalation of Ubuntu. I installed a couple of fonts (droid, mscorefonts). I did not change any font settings.

LINK TO SCREENSHOT

Fonts in other applications looks great. When I open the very same text in Google Docs or MS Web Word, it looks perfect.

I would appreciate any help concerning this issue. Thanks!

  • 1
    The font rendering in your example looks a but different but you might be facing a similar issue to the one I was facing a year go. Please try and see if the solution outlined in this Q&A works for you. – Glutanimate Dec 4 '13 at 17:06
  • @Glutanimate Thank you! Before applying the solution, the fonts looked like bitmaps... low resolution ones at that, after perfect. – Quaternion Feb 1 '14 at 21:49
2

I answer this old thread because I experienced the same problem and I just solved it with a different method. I run Ubuntu 16.04 and LibreOffice 5.1.4.2.

Essentially, I took the answer proposed by Fitoschido in this thread: https://ask.libreoffice.org/en/question/7127/calibri-font-not-rendering-correctly/

In short, one has to edit (or create) ~/.config/fontconfig/fonts.conf and add the following block:

<match target="font" >
  <edit name="embeddedbitmap" mode="assign">
    <bool>false</bool>
  </edit>
</match>

This has the effect of bypassing the bitmaps of the characters embedded in MS fonts and getting Ubuntu/Linux to apply anti-aliasing as I should. Now, MS fonts look much, much better in LibreOffice.

2

This worked for me on Ubuntu 16.04 with KDE

Open KDE System Settings > Fonts > set Use anti-aliasing: field into Enabled > click Configure > dialog Configure Anti-Alias appears > set Sub-pixel rendering type: field into RGB > set Hinting style: field into Slight > press OK > press Apply > restart your programs (LibreOffice etc.).

Credit goes to http://www.ubuntubuzz.com/2016/03/how-to-fix-ugly-libreoffice-font-rendering-kde.html

0

If the bug is only with a single font:
You can find the fonts in /usr/share/fonts/truetype and edit them with any application you like.
Remember that in the Ubuntu repository you can find alternative versions of almost any character; often, open versions are better than proprietary ones.
If the bug is with many fonts:
A temporary solution is to use substitution table in character styles options to substitute the bad font with the good ones. You can also set the default fonts in the Writer options.
Another solution can be to tweak the characters options for the page: right click -> characters -> position -> distance. And make it fixed by disabling the default, it should be better.
If you can't solve, please consider of downgrading your libreoffice with Synaptics package manager (Menu -> Package -> Force version).
Hope you solve, my eyes would implode with a similar bug. :)

EDIT: if one of the following solutions works try to tweak the font rendering configuration by editing the files in /etc/fonts/conf.d/; use sudo nano /etc/fonts/conf.d/FILENAME on a terminal to do it.
For example try to disable font antialiasing by editing 10-antialias.conf (replace true with false); the same for 10-hinting.conf. If nothing changes symply re-replace false with true.
Please note that you will disable these features for the whole system, so revert the changes if they doesn't help.
The last possible cause of your problem can be the graphic rendering of the driver itself. You can try to execute sudo nano /etc/libreoffice/soffice.sh and ENABLE/DISABLE the OpenGL support. Restart Libreoffice after each edit.
If you can't solve downgrade or use OpenOffice or an equivalent suite, for your eyes (I'm not kidding).
I'm sorry if I wasn't of great help, but I don't know the source code of LibreOffice, I'm only trying various possibilities. :-)
Let us know if you solve or if you discover interesting things.

  • Thank you very much for your reply. My eyes are actually imploding every single time... I tried all the options and suggestions (apart from downgrading) and none of them help. Apparently all fonts are plagued with this issue. Some are worse, some better, but neither of them is actually good-looking and usable. The situation changes with the level of zoom which is strange. I do not understand this very well, but it seems to me that Libre Office just use a different setting for antialiasing or any similar font feature. AbiWord looks much better. – tuhyk Nov 2 '13 at 16:17
  • Maybe I have a better solution. I'll edit the answer in a moment... – Lorenzo Ancora Nov 2 '13 at 20:50
  • Thanks a lot @Lorenzo for your efforts. I have been trying the above mentioned suggestions but unfortunately none of them helped. In the mean time I have tried Elementary OS (with bundled old version (3.6.something) and I experienced the very same issue. So I guess this is not related to version. It must be something directly in my system, perhaps graphics driver? I have Thinkpad T400, Intel based. BTW - when I switch the hinting to full, it brings considerable improvement in Libreoffice, but the rest of the system is much worse (for my eyes). Can I sent hinting for one application only? – tuhyk Nov 3 '13 at 19:24
  • No, you can't force the hinting behaviour for one application only; this is alien technology and we can't have it, sorry. :-D But, you can do a good thing by going to your system --> window style options and select the font options to change the hinting level; it's graphic enviroment dependent and the effect also depends also on your (I hope LCD) monitor. (wait a few seconds after every change) ... if you still have problems we can make a script to enable/disable hinting on the fly, and it can also help other users, but the final solution is of the LibreOffice developers, not ours. :( – Lorenzo Ancora Nov 7 '13 at 19:57
0

LibreOffice doesn't use anything but the freeware font engine so all MS and Monotype fonts will look bad as they are hinted or prepped for the Windows font engine.

Also, LibreOffice doesn't license any fonts from monotype so it's not the best solution if you create a document in Times New Roman in MS office, then open it up in LibreOffice - it will default to some random opensouce (typically poor quality) font.

0

I want to share how I solved my problem with the ugly font rendering in LibreOffice.

First of all, I have to point out that after a fresh OS reinstall, I usually don't install the whole office suite, but only the LibreOffice Writer. Then I open some document and the font rendering is ugly. But I noticed that when I install the whole LibreOffice suite this problem is not present - the fonts are looking fine.

So I concluded that the correct rendering depends on something that is excluded from the installed packages when you install the Writer only. I tried installing different packages and I found that this is the libreoffice-gtk package. So, check out if it is installed on your system. I use Lubuntu 14.10 (GTK interface), so I suppose that's why this works for me.

0
sudo apt-get install libreoffice-gtk3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.