Running VMware WS 10 on Windows 7. EASY-installed Ubuntu desktop 12.04 64-bit. Windows Task Manager seems to say VMware is running 32 bit, but I have a FreeBSD 64-bit guest running, and a Windows 8 64-bit guest running as well. Any pointers or clues will be most appreciated.

  • 5
    The problem is in Windows and VMware. This is not about Ubuntu, even though Ubuntu is mentioned. – Olli Feb 24 '14 at 11:20
  • Perhaps one day, VMWare will hire some people who know how to A) make their software more robust, and B) write meaningful error messages. I look forward to that day. – Jonathan Wood Aug 3 '15 at 22:29

This issue can occur when the VMware Authorization service is not running or when the service does not have administrator rights.

To resolve this issue, start the service and ensure that it does have administrator rights.

To start the VMware Authorization service or to check whether it's running: Login to the Windows operating system as the Administrator. Click Start and then type Run. If you are unable to find the Run option, refer to Microsoft article What happened to the Run command? Type services.msc and click OK. Scroll down the list and locate that the VMware Authorization service. Click Start the service, unless the service is already is showing a status of Started.

  • 2
    I used "Run as administrator" when starting workstation, and it worked. – user1007727 Jul 29 '14 at 16:30
  • TYVM! This caused me a mini heart attack. – womp Dec 9 '15 at 18:34
  • Just starting the service did it for me. – Edward Olamisan Mar 2 '16 at 3:13

In case the VMWare Auth service is running and you are still getting this error, follow the given steps,

  1. Close VMWare
  2. Stop any VMWare processes (from Task Manager)
  3. Delete the .vmem file
  4. Re-start the VM and it would work fine

Hope it helps

  • 5
    also you can start the service: win+r, type "services.msc", right click on "VMWare Authorization Service" and the start – Totty.js Dec 29 '13 at 17:14
  • 1
    The comment above did the trick for me. – arberg Aug 7 '15 at 11:53

You may discover that the option to start the Vmware Authorisation Service has been disabled and the option to start it has been greyed out.

In that case, right click the service, followed by Properties. Change the Startup Type to your desired status (eg. Automatic (Delayed Start)), then click Apply, followed by Start.

You can also just run Workstation as an Administrator if you want.

Right-click VMware Workstation in the Start Menu Icon or on the Desktop Shortcut Icon, followed by "Run as administrator".

  • This is not a helpful comment "guntbert". Instead of marking the reply down, it would be more useful to explain the reasoning behind the statement. – GeckoSEO May 10 '14 at 21:08
  • There is nothing wrong with manually starting the VMware Workstation services as Admin. In fact it is preferable, since it means the startup of the service is authorised on a case by case basis.This is the opposite of running the service with Admin rights by default. This is about a local installation of the VMware Workstation product, not a publicly accessible virtual server. It is in fact not possible to run the virtual server in VMware Workstation if the host security settings are robust enough, and in the case of a PC, this is a far greater security consideration. – GeckoSEO May 10 '14 at 21:19
  • What comment are you referring to? Did I say "Don't run VMWare as administrator"? – guntbert May 11 '14 at 10:11
  • Yes..The comment appears to have been deleted. The topic itself is not actually related to Ubuntu, but the question arose by attempting to run an Ubuntu server as a guest in a Workstation environment. It could in fact arise with any guest. The reason it happens is due to the services not starting, and they can be changed to start automatically which solves the run as administrator requirement for starting the VMware program. However this is a security risk, because it also enables autorun of the network disks. I think the question itself is still useful if it helps others solve the problem. – GeckoSEO May 11 '14 at 10:53

In my case I am running VMWare workstation V.10 on Windows server 2008 R2. I had to remove my server from domain and VMware started giving "Internal Error" while starting guest machines. I have tried couple of work-a-rounds.

finally Re-installing VMWare with repair option resolved the issue

Not the answer you're looking for? Browse other questions tagged or ask your own question.