I know that my question can be a duplicate, but i spent a lot of time with google and askubuntu, but couldnt find answer.

I installed Ubuntu 13.10 alongside Windows 7 (i had C drive of 100GB and D drive of 200GB). While installing,i allocated 80GB for Ubuntu from D drive. So after installation i couldnt boot into windows. Using tools gparted, Ubuntu Boot repair and testdisk i tried to repair boot but (as i guess) removed smth important from SDA...

So after restart i have grub rescue prompt. All partitions are unknown filesystem. I tried to boot into LiveUSB Ubuntu 13.10 ... as i had Windows partition on sda1, and linux-swap on sda2... and 130GB unallocated memory (as i guess its D drive) ... I have a lot of important information on D drive.

So how i can recover partition ?

Any help be appriciated!

  • 1
    You should try using Boot Repair(from the liveUSB) and see if the recommended repair will help. Note the url that it gives you so that you can link to it, it will provide valuable info on what Boot repair did and why it might have failed. The URL may only be shown if Boot Repair fails, I can't quite remember(but I think that it will export the info either way). Don't mess with any of the other tools that you used before, just post the link for your system info. (You don't want to mess with the other tools yet, it will change the info after it was linked making it outdated) – TrailRider Nov 1 '13 at 20:17
  • thank you for your answer, but i've tried many times using Boot Repair tool, but it was'nt useful ... – davitp Nov 2 '13 at 10:32
  • well it wasn't so much of an answer as a comment, from what I read of your question I didn't think it would work,but, the important part of my comment(and the reason I suggest that you run it one more time), was to get the link for your boot info and post it to your question...while boot-repair will fail if there is a problem with your computer that is more than just a bad grub, the pastebin file it uploads, gives info that will be needed to diagnosis your problem. There are ways to get it otherwise by running a slew of terminal commands but re-running boot-repair is the easier option by far – TrailRider Nov 2 '13 at 15:32
  • I think your partition table got out of order. Check out my answer in the end to my own question. askubuntu.com/questions/420778/… – kenn Aug 29 '14 at 10:30

Boot from a live system, and use the gpart utility to scan for file systems.


try :

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

it should detect missing MBR and fix it. it did for me but I do not know if this means it would also restore windows bootability, but that's this app's job so it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.