1

I'm a Linux Novice

Was running 12.04 with virtualbox 4.2. Everything was rosie.

Upgraded to 12.10; now Virtualbox will run, but can start any VM's. Get error 'kernel driver not installed' I've ran /etc/init.d/vboxdrv setup but get error 'Your kernel headers for kernel 3.8.0-32-generic cannot be found'

I tried running apt-get linux-headers-3.8.0-32-generic but get error 'Pakcage linux-headers-3.8.0.32-generic is not available, but is referred to by another package'.

uname -r responds with 3.8.0-32-generic

ls /usr/src contains linux-headers-3.5.0-42; linux-headers-3.5.0-42-generic & vboxhost-4.3.0

How do I resolve this? I now understand I should have installed DKMS before performing the OS upgrade and kernel headers would have been updated.

  • Search for a file called "vboxdrv.ko". In the same folder there are some other libraries as well. Try to manually load them into the kernel by using "sudo insmod <libfile>". To search for a file use "find / -name <filename>". If that's the cause of your problem it can easily fixed by adding those libs into the kernel during boot. – tombert Nov 1 '13 at 18:37
  • When I run sudo insmod vboxdrv.ko but it fails with -1 Invalid module format – bigmac Nov 1 '13 at 19:13
  • 1
    I tried running apt-get install linux-headers-$(uname -r) but that fails with error message 'Package linux-headers-3.8.0-32-generic is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source. E: Package 'linux-headers-3.8.0-32-generic' has no installation candidate' – bigmac Nov 1 '13 at 19:38
  • Sorry but then I cannot help on this other then suggest to try re-installing virtualbox. It seems that the modules do not fit the kernel ... but thats a wild guess. – tombert Nov 2 '13 at 7:24
0

Install all kernel package include kernel-header, with a newest kernel (3.11.0-13 (binary) with synaptic. Then reboot . The system will start with new kernel and ... work. (my problem is using vmware)

If you have a problem with 3.5.0-42 you can start with old one.

-1

Most of the time this is the fix for me.

sudo apt-get update
sudo apt-get install dkms
sudo reboot 

If that fails try:

sudo apt-get remove virtualbox
sudo apt-get install virtualbox
sudo reboot

Don’t worry you will not lose any of your created virtual machines.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.