Since updating to Ubuntu 13.10, Shockwave Flash does not work in Chromium or Firefox. Both show a "Shockwave Flash has crashed" dialog.

Chromium 29.0.1547.65

After loading a page with a Flash video, I get this warning on the console twice:

NVIDIA: could not open the device file /dev/nvidia0 (Operation not permitted).

When I try to play the video, it crashes and I receive these disorted error messages:

(exe:14868): Gdk-WARNING **: XID collision, trouble ahead
[xcb] Extra reply data still left in queue
[xcb] This is most likely caused by a broken X extension library
[xcb] Aborting, sorry about that.
owser --type=plugin --plugin-path=/usr/lib/flashplugin-installer/libflashplayer.so --lang=de --channel=14560.18.20766867: ../../src/xcb_io.c:576: _XReply: Assertion `!xcb_xlib_extra_reply_data_left' failed.

Firefox 25.0

With Firefox, I get these errors:

###!!! ABORT: Request 154.24: BadValue (integer parameter out of range for operation); 3 requests ago: file /build/buildd/firefox-25.0+build3/toolkit/xre/nsX11ErrorHandler.cpp, line 157
WARNING: pipe error (110): Connection reset by peer: file /build/buildd/firefox-25.0+build3/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 437

###!!! [Parent][RPCChannel] Error: Channel error: cannot send/recv

What I tried so far

  • Reinstalling flashplugin-installer
  • Changing permissions of /dev/nvidia0
  • Tried Google Chrome 30.0.1599.114, which works perfectly with its own Flash plugin.

It seems that Flash Aid is no longer available. GPU acceleration is working fine, e.g. for Portal.

Does anyone know how to fix this?

  • Maybe it's related to your locale, try LC_ALL=C chromium-browser – kenn Feb 20 '14 at 13:23
  • It seems that the error has become less repeatable in Chromium, but starting Firefox with the locale "C" does not fix the problem. – Stephan Windmüller Feb 20 '14 at 17:08
  • Did you take a look at this link bbs.archlinux.org/viewtopic.php?id=163158 ? It can be permission issue – kenn Feb 20 '14 at 21:49
  • As I wrote in my original question, I already altered the permissions of the nvidia0 device without success. – Stephan Windmüller Feb 23 '14 at 11:49

If You Must Use Flash

Generally speaking, my understanding is that Adobe no longer supports flash in Linux - but that the Google Chrome project has decided to integrate and support flash on their own. So Google Chrome would be the only browser that you can use at the moment out of the box, so to speak.

I have managed to get flash to work on other browsers from a recent install on an older 32 bit machine by using a flash-sse plugin (Shockwave Flash 11.1 r102). This build is made for chips that do not have SSE support. I don't know what machine you are using but this is important information.

This was not on an Ubuntu machine but an Arch Linux box running Gnome, but you should be able to find an older version of flash or flash-sse for Ubuntu.

What will happen is that the newer versions of Firefox (I have v27) will block older flash versions automatically with a security warning. You will have to click Activate ... and then Allow ... to view flash. Personally I prefer this as I don't like flash adverts streaming to my machine and using bandwidth.

The security risk, if any, can be mitigated somewhat by sending file locations to &>/dev/null, so that all data streaming in will be shredded on arrival.

[update] I have just installed Chromium v32+ and the above setup (Shockwave Flash 11.1 r102) works for Chromium too - without the grumbling that Firefox exhibits.

For Ubuntu you might be able to find a Debian package that will work. A good link to follow is https://wiki.debian.org/FlashPlayer. It seems that Flash 11 is the last version to work on Linux.

Otherwise Use HTML5

Alternatively, you can enable HTML5 instead of flash on any HTML5 capable browser (especially Chromium) by following this link https://www.youtube.com/html5 and clicking Request the HTML5 Player. From this point forward your Youtube videos and some others will play on any HTML5 capable browser, but I found on my older machine this was too resource intensive. On newer machines I don't think this will be a problem. This is where all streaming content is headed anyway and is why Adobe Flash will be phased out in the longer term.

| improve this answer | |
  • HTML5 works great. Who wants proprietary stuff anyway, right? – PyRulez Feb 23 '14 at 21:08

Unfortunately or fortunately Shockwave stopped support of Linux, currently latest version of it is 11.02 in Linux. Firefox is developing shumway but it's far from replacing flash for the time being. The only alternative or best solution is to use pipelight. It's running flash, shockwave, silverlight and unity player through wine http://fds-team.de/cms/pipelight-installation.html Though your problem seems to be related to vidoe module of your hardware you can give a shot to pipelight. I have been using it for months, it's seemlessly integrated in your browsers like chrome, firefox, opera.. all works well. It's using the latest version of flash.

| improve this answer | |
  • I've actually tried pipelight in a recent Ubuntu installation (for example BT Sport in the UK is Siverlight based) and could not get it to work for that purpose. There are issues with pipelight too. – AsymLabs Feb 20 '14 at 10:55
  • The only issue I met was crashing of the plugin when I minimized the browser but it's not a common bug. – kenn Feb 20 '14 at 11:01
  • @AsymLabs Did you also try flash with pipelight? Actually silverlight works better than flash in pipelight. I didn't notice any performance slowness in silverlight though configuration of my laptop is not good. – kenn Feb 20 '14 at 11:09
  • pipelight worked fine for many websites but the BT Sport website would not work. It seems to be related to security or cookie capabilities that wine/pipelight cannot offer. Unfortunately for Linux there are few alternatives for Siverlight functionality. – AsymLabs Feb 20 '14 at 11:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.