I'm trying to install MaaS with Ubuntu 12.04.3 LTS (server).

I added extra repos, as suggested in https://juju.ubuntu.com/install/ and http://www.ubuntu.com/download/cloud/cloud-archive-instructions.

add-apt-repository ppa:juju/stable

and in /etc/apt/sources.list

deb http://ubuntu-cloud.archive.canonical.com/ubuntu precise-updates/havana main

Then when navigate to http://<my-host>/MAAS I get 500 Internal server error

tail /var/log/apache2/error.log

[Fri Nov 01 17:02:57 2013] [error] [client]   File "/usr/share/maas/maas/urls.py", line 25, in <module>  
[Fri Nov 01 17:02:57 2013] [error] [client]     url(r'^', include('maasserver.urls')),  
[Fri Nov 01 17:02:57 2013] [error] [client]   File "/usr/lib/python2.7/dist-packages/django/conf/urls/__init__.py", line 25, in include  
[Fri Nov 01 17:02:57 2013] [error] [client]     urlconf_module = import_module(urlconf_module)  
[Fri Nov 01 17:02:57 2013] [error] [client]   File "/usr/lib/python2.7/dist-packages/django/utils/importlib.py", line 35, in import_module  
[Fri Nov 01 17:02:57 2013] [error] [client]     __import__(name)  
[Fri Nov 01 17:02:57 2013] [error] [client]   File "/usr/lib/python2.7/dist-packages/maasserver/urls.py", line 22, in <module>  
[Fri Nov 01 17:02:57 2013] [error] [client]     from django.views.generic.simple import direct_to_template  
[Fri Nov 01 17:02:57 2013] [error] [client] ImportError: No module named simple  


dpkg -S /usr/lib/python2.7/dist-packages/maasserver/urls.py  

I know some python but I don't know much about django. Google suggests I need a version of python-django-maas that is updated to django 1.5.

In that case can I have some help with backport or apt pin?

Otherwise what am I doing wrong?

Thanks, Drew

  • http://askubuntu.com/questions/359201/step-by-step-install-of-maas-and-juju suggests sudo add-apt-repository ppa:maas-maintainers/stable but python-django-maas is 'kept back'. Can I override 'kept back'? – user210146 Nov 1 '13 at 7:10

The cloud archive repository is for the machines Juju and MaaS will be managing, but not for the MaaS server itself. Try removing the line

deb http://ubuntu-cloud.archive.canonical.com/ubuntu precise-updates/havana main

from /etc/apt/sources.list. (Later on, there are ways to tell Juju to use that repository on the machines it is managing. In fact, those are configuration options that are part of the Juju Openstack charms.)

If you are running the Juju client from the MaaS server (instead of from say your personal machine, and just having it connect from your personal machine to the MaaS server API), you don't need the Juju PPA on the MaaS server either.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.