Problem: Black screen after resume

I found the below statement that I provided the link for but, no instructions with it for a person that's new to Ubuntu on what exactly to do to fix the problem. Can someone clarify this for me? Thank you.

Ubunu 13.10 AMD A6-3420M APU with Radeon(tm) HD Graphics × 4 64bit Toshiba L775

My computer boots to a black screen, what options do I have to fix it?

Typical scenario is "use a laptop docked with lid closed, only the external screen is active, suspend, take the laptop, open it somewhere"... which leads to "no screen active".

To debug this problem, check if gnome-settings-daemons is getting a signal that the display configuration has changed, by running xtrace against it, and look for a RRScreenChangeNotify event when resuming the machine. If that signal is being sent, then it indicates a possible bug in g-s-d. Otherwise, it suggests a bug in either X or (more likely) the kernel which is not causing the signal to be emitted to begin with.


I had this problem before too. this will disable Energy Star (DPMS) features:

DISPLAY=:0 xset dpms force off

for more info ...

man xset

  • Than for the reply. I just got my dual monitors and my keyboard working. It's a miracle! I wanted to come back and post what worked this time and will hopefully keep working for a while. – Robert Nov 2 '13 at 14:16
  • never mind. now that ive restarted still no key board and blan i think im just going back to amd. ive spent too much time on this already. way to much time. – Robert Nov 2 '13 at 14:47
  • OK, thanks for the info, sorry to hear that you gave up. I'm no linux expert but personally the learning experience is the reward. That said there is a lot to cover, I've just clocked up my 5th year of linux desktop and I still can't get everything working most days. anyway... if xset did solve the problem then you need to make it "stick". I have nvidia card so I use sudo nvidia-settings which is not much help to you but there must be an ATI settings program. failing that you maybe could add the xset line to /etc/rc.local just above the "exit 0" line – user210146 Nov 3 '13 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.