5

Tap to click is usually the first thing I disable when I have installed a new OS, but this time I couldn't get rid of it. In earlier versions of Lubuntu, I was able to disable it by writing @synclient MaxTapTime=0 to /etc/xdg/lxsession/Lubuntu/autostart and save. But in Lubuntu 13.10 this method doesn't work any more. I can't find any solution on the internet either.

(If there was a checkbox in "mouse and keyboard" preferences in LXDE to turn tap to click on/off permanently, like in Unity, that would make both lovers and haters of this divisive feature happy. I don't understand how this feature could be thought of as something everybody wants.)

  • Strange. I have almost the same thing working in Xubuntu 13.10. I have a user script that runs under Session Autostart Apps. My script contains: "/usr/bin/synclient MaxTapTime=0" – Sean Nov 1 '13 at 2:23
4

Click on the Menu icon in your panel. Choose Preferences in the dropdown and then choose Customize default applications for LXSession. This is a new feature in Lubuntu 13.10. There's no documentation that I know of as yet.

A screen will open as shown below:

Customize default apps for LXSession

  • Click on the Autostart tab. You should see something like what is shown in the image.
  • Ensure that config-only appears next to Disable autostarted applications.
  • Under Manual autostarted applications and next to + Add, type in synclient MaxTapTime=0
  • Close the Customize default applications for LXSession window.
  • Just to check, open ~/.config/lxsession/Lubuntu/autostart. You should see a line with synclient MaxTapTime=0. There's no need to do anything. Just close the file.
  • Log out.
  • Log in.

Tap to click should be disabled now. This works for me in Lubuntu 13.10.

  • Perfect! This solves my problem! Thank you so much! :-) – radiomasten Nov 1 '13 at 13:18
  • What is the menu icon in the "panel" ? What is the panel? Do you have any screenshots? The keypad tapping is driving me nuts. It was easy to disable even in Windows 8. I think it should be under system settings -> mouse and touchpad, but the only thing there is clicking speed, which is pretty useless. – user262435 Mar 26 '14 at 23:34
  • doesnt work any more: askubuntu.com/questions/802645/… – Woeitg Jul 25 '16 at 10:47
  • user25656's instructions do work in Lubuntu 16.04.1. The "Panel" is the taskbar. Click the Lubuntu icon in lower-left to bring up the "start menu", select "Preferences", then in the sub-menu select "Default Applications for LXSession". Follow instructions as given by user25656 and remember to click the "Add+" button after typing in the "synclient..." line. If you have done this, the line will appear under the bold text "Manual autostarted applications". To try it out without rebooting just type "sudo synclient MaxTapTime=0" in a shell/terminal. – Robert Munafo Aug 10 '16 at 7:42
  • "sudo" not needed, sorry :O it's a per-user setting. – Robert Munafo Aug 10 '16 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.