I've tried several solutions I found on the web, but didn't manage to solve a problem.

Since today my laptop won't find my WiFi network, but neighbours' networks are suggested. Another laptop with U12.04 does find one.

What do I do?

I've Dell Latitude-E4310,

02:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
    Subsystem: Dell Inspiron M5010 / XPS 8300
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at f2c00000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: brcmsmac
    Kernel modules: bcma, brcmsmac


NetworkManager Tool
State: connected (global)
- Device: eth1 -----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            wl
  State:             disconnected
  Default:           no
  HW Address:        1C:65:9D:7A:45:5C

  Wireless Properties
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

Should I provide anything else? Many thanks in advance.

UPD: http://pastebin.com/NfzBK2HQ

  • 1
    It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the contents of the file here pastebin.com then paste the link back here. No internet then go to this link for running the script without internet. [url]ubuntuforums.org/showpost.php?p=12350385[/url] – Wild Man Oct 31 '13 at 22:12
  • @WildMan, done. pastebin.com/NfzBK2HQ – Anton Nov 1 '13 at 6:00
  • These answers are too complicated. If Ubuntu is trying to usurp the tyrants these answers must be something the masses can understand. – user254535 Mar 4 '14 at 4:56

Please do:

sudo apt-get purge bcmwl-kernel-source
sudo modprobe -rv wl
sudo modprobe -v brcmsmac

if there are any errors please continue with the commands then reboot. your wireless should be working now.

  • It seemed to me I've tried doing this. Well. I must have done too many modifications in sequence (not quite understanding what I was doing) :) This worked. Awesome. You saved me, thank you! – Anton Nov 1 '13 at 17:22
  • Make sure it works after a reboot, we may have to unblacklist a driver or two. – Wild Man Nov 1 '13 at 17:29
  • Everything works perfectly. So a wrong driver was a problem? – Anton Nov 2 '13 at 20:00
  • Yes it was the wrong driver. – Wild Man Nov 2 '13 at 20:16
  • wow. thank you very much, man. this tip saved my life. – androidevil Apr 8 '14 at 3:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.