5

Since upgrading to 13.10 from 13.04 my mouse no longer connects via bluetooth. In settings it states that the mouse is not paired. Restarting bluetooth with sudo /etc/init.d/bluetooth restart does not help. Restarting the computer does fix the problem if bluetooth is restarted also with the previously mentioned command, but this is not ideal.

The mouse worked fine prior to updating to 13.10.

The computer is a ThinkPad X230 with a Broadcom 'BCM20702A0' bluetooth module (I think).

When it is not working hciconfig hci0 -a returns:

hci0: Type: BR/EDR Bus: USB

BD Address: C0:18:85:DB:F3:D1 ACL MTU: 1021:8 SCO MTU: 64:1

UP RUNNING PSCAN

RX bytes:766129 acl:49888 sco:0 events:2233 errors:0

TX bytes:5953 acl:240 sco:0 commands:274 errors:0

Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87

Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3

Link policy: RSWITCH SNIFF

Link mode: SLAVE ACCEPT

Name: 'BCM20702A'

Class: 0x6e0100

Service Classes: Networking, Rendering, Capturing, Audio, Telephony

Device Class: Computer, Uncategorized

HCI Version: 4.0 (0x6) Revision: 0x1000

LMP Version: 4.0 (0x6) Subversion: 0x220e

Manufacturer: Broadcom Corporation (15)

When it is working hciconfig hci0 -a returns:

hci0: Type: BR/EDR Bus: USB

BD Address: C0:18:85:DB:F3:D1 ACL MTU: 1021:8 SCO MTU: 64:1

UP RUNNING PSCAN

RX bytes:253334 acl:16391 sco:0 events:842 errors:0

TX bytes:2519 acl:65 sco:0 commands:84 errors:0

Features: 0xbf 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87

Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3

Link policy: RSWITCH SNIFF

Link mode: SLAVE ACCEPT

Name: 'ubuntu-0'

Class: 0x6e0100

Service Classes: Networking, Rendering, Capturing, Audio, Telephony

Device Class: Computer, Uncategorized

HCI Version: 4.0 (0x6) Revision: 0x1000

LMP Version: 4.0 (0x6) Subversion: 0x220e

Manufacturer: Broadcom Corporation (15)

I am a relative novice with linux so don't ask me compile anything please, but I can use google.

Update 1: I noticed when I checked the bluetooth settings page that the mouse is reported as being not paired even while it is operating correctly.

I have tested with a bluetooth headset now also and it gives similar issues (no sound after resume from sleep), but in this case it is being reported as paired.

  • I'm just pasting here the diff between the two outputs you pasted: 5c5 < RX bytes:766129 acl:49888 sco:0 events:2233 errors:0 --- > RX bytes:253334 acl:16391 sco:0 events:842 errors:0 7c7 < TX bytes:5953 acl:240 sco:0 commands:274 errors:0 --- > TX bytes:2519 acl:65 sco:0 commands:84 errors:0 17c17 < Name: 'BCM20702A' --- > Name: 'ubuntu-0' Maybe you can include that information in your question so that it's easier for the people that might be able to help. – Anton Petrov Nov 2 '13 at 11:22
2
+50

Bluetooth settings are controlled from configuration files in /etc/bluetooth. For input devices we can define a timeout before a connection will be disconnected. To disable this open /etc/bluetooth/input.conf as root in an editor and either comment out the following line by adding # (as it is done in the example below), or set timeout value to 0:

#IdleTimeout=30 (set to 240)

Other timeouts that can be set in /etc/bluetooth/main.conf may not be affected in your case as they only play a role when a service may be interrupted (e.g. by bad signal strength) and will not be reconnected in case a timeout is set here. Default values for timeouts in main.conf are:

DiscoverableTimeout = 0 Set to whatever
AutoConnectTimeout = 0 Comment this out
PairableTimeout = 0 Set to whatever
PageTimeout = 8192

Also set RememberPowered to false in main.conf

Follow the above instructions to set a longer timeout for reconnect. About the unpairing, it is probably due to Ubuntu thinking the device is gone.

Source: Bluetooth mouse not auto-reconnecting

  • Thanks for the info, but nothing worked here. – Korakys Nov 6 '13 at 21:13
  • Continued from above. IdleTimeout was already commented out. I set it to =0. I set the main.conf parameters to 60 and changed RememberPowered to false. Restarted and nothing changed. I will have a look into the source link now. I've updated the question text with new info as well. – Korakys Nov 6 '13 at 21:25
  • Sorry to hear that. That was the only info I could get. – Kaz Wolfe Nov 6 '13 at 21:45
1

It seems that the bluetooth device is not longer being powered up automatically.

Try this: create a new file /etc/udev/rules.d/99-bluetooth.rules with the following contents.

# Set bluetooth power up
ACTION=="add", KERNEL=="hci0", RUN+="/usr/sbin/hciconfig hci0 up"

edit: hciconfig is in /usr/sbin/ not /usr/bin/

  • Sorry, this didn't help. – Korakys Nov 17 '13 at 19:04
0

I'm not sure why, but I tried to use my mouse after waking the laptop recently and this problem is no longer happening for me.

  • Maybe because the original advice eventually worked? :) – Tek Dec 23 '14 at 22:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.