9

After upgrading to Ubuntu 13.10 I have no sound for HTML5 players in Google Chrome Browser.

Firefox works.

Flash Players are working.

No sound on Youtube when using HTML5. No sound on vimeo (They have html5 player as standard).

When I open the soundapplication, google doesn't show up when I try to play a html5 video. But it shows up, when playing a Flash Video.

Google Chrome Version is: 24.0.1312.52

Installed an updated via ppa:

deb http://dl.google.com/linux/chrome/deb/ stable main
  • 2
    Close voters: This seems to be a legit issue and has a useful answer, I see no reason to close this. – Seth Dec 29 '13 at 0:57
  • 1
    Regarding close voting: None of the close reason is true: Problem can be reproduced, it didn't "went away" and it seems to be relevant to others (See 3 upvotes on answer and 2 on question). So it could help other future readers. – rechengehirn Dec 30 '13 at 13:54
3

I fixed it. Here is the complete journey:

I tried to install a new version (30.0.1599.114) of Chrome with a deb package.

Installation went O.K. but Chrome still said: Version 24.0.1312.52 in "About Google Chrome). Sound in HTML5 Players still didn't work.

I deleted the ppa. Installed deb package again. Still the same.

Then I moved my profile folder. Restarted Google Chrome and suddenly I had the new version. And HTML5 sound works.

To move the profile folder:

mv ~/.config/google-chrome ~/.config/google-chrome_bak

This will delete all your passwords and favorites etc. But if you have google chrome syncronization you can recover it.

  • According with this comment, you reinstalled your chrome. What is your chrome version now? – Radu Rădeanu Oct 31 '13 at 21:07
  • Radu Rădeanu: I have editet the solution to prevent confusion. Thanks for helping me. – rechengehirn Nov 1 '13 at 9:59
2

I tried the radical solution of moving the config folder and it worked, but I was unsatisfied with the fact that I lost all my distro-specific config.

So after restoring it and looking deeper into the matter, I noticed that in YouTube (where I found the problem; hadn't checked anywhere else), I had the videos muted. After unmuting it worked.

I know this sounds rather dim-witted, but maybe this answer will help someone else before making any drastic changes!

enter image description here

0

You should upgrade to the latest official version of Google Chrome which now is 30.0.1599.114.

To do this, just click on the the following link, select your Ubuntu flavor (32 bit or 64 bit), accept the terms of service and install: https://www.google.com/intl/en/chrome/browser/?brand=CHMO#eula

After the .deb package is downloaded, just (double) click on it to install it.

  • 1
    Well. I already did that. But when i go to "About Google Chrome" it still says: 24.0.1312.52 While in the software-center it says: Version 30.0.1599.114 And as I wrote, chrome is installed via ppa - which sould update automaticaly. – rechengehirn Oct 31 '13 at 19:14
  • @rechengehirn Have you uninstalled the old version? – Radu Rădeanu Oct 31 '13 at 19:18
  • @rechengehirn What is the output of this command: apt-cache showpkg google-chrome?? – Radu Rădeanu Oct 31 '13 at 19:20
  • Thank you for trying to help me. Here is the output: Reverse Depends: google-chrome-unstable:i386,google-chrome [and some more of that...] Dependencies: Provides: Reverse Provides: google-chrome-unstable 32.0.1685.0-1 google-chrome-stable 30.0.1599.114-1 google-chrome-beta 31.0.1650.39-1 – rechengehirn Oct 31 '13 at 19:25
  • I also uninstalld with apt-get remove. Removed the ppa and then installed with the .deb package. But still the same. Btw. Sound in HTML5 Player works in chromium too. – rechengehirn Oct 31 '13 at 19:28
-1

Try this for a quick fix from terminal window:

sudo ln -s /usr/lib/mozilla/plugins/ /opt/google/chrome/plugins
  • 3
    Please clarify this part: /plugins//opt. What about the //. Please edit your answer and use proper formatting and some more details, on what the command given does/improves. Two different directories for some, but not so obvious for others! – v2r Jul 4 '14 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.