I've completed an install of Ubuntu Server 13.10 within VMware and am running into a problem configuring the console (non-graphical) resolution.

When I was running Ubuntu Server 13.04, I ran into the same problem. posted the question here, which I later solved by editing /etc/default/grub thus:


I then ran sudo update-grub, sudo reboot and 13.04 stuck in a larger-size console mode... just what I wanted. BUT when I run the same commands in 13.10, during the reboot it changes to the new screen-res, BUT the screen stays black and I can't interact with it. I power down the VM, go back to a previous snapshot, and try again... and again.

Since the hwinfo package is no longer available, I can't run sudo hwinfo --framebuffer to see what options are available.

Ideas anyone?

Here are the uncommented settings in my /etc/default/grub file at this moment:

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

An alternative option, in short -

  1. A. Either use bridged network to guest

    B. Or, follow directions at [1] to forward port 22 (ssh port) to a host port

  2. SSH to the host port (and thereby to the guest), using Putty or any other ssh client. The ssh client should give you a re-sizable console.


I recently upgraded my VM and ran into the same problem. I tried various combinations of values for GRUB_CMDLINE_LINUX_DEFAULT, GRUB_GFXMODE, GRUB_GFXPAYLOAD, and GRUB_GFXPAYLOAD_LINUX to no avail. I have gone for an alternative that now works better for me.

Essentially, I use Putty to ssh into my VM. This gives me a re-sizable console. Copy-paste also works better now between Windows and the shell. Since I choose the NAT option for my VM, this approach is less straight-forward. I use the directions in [1] to get access to the VMware network configuration editor. I then forward guest port 22 to a host port (say 8122), and then ssh to it (localhost:8122) from Putty running on my Windows host.

[1] http://alexduan.com/2012/10/15/vmware-player-5-0-network-editor/


I see grub_gfxmode=800x600, have you tried other settings there ?

You might be able to work around this with uvesafb: http://cosmicb.no/2013/12/25/ubuntu-13-10-console-resolution/

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.