I have Chromium web browser on my Lubuntu 13.04 (pre-installed). I use LX Terminal (pre-installed) to write commands. I am trying to download flash player on Chromium using instructions on this site:

sudo add-apt-repository ppa:skunk/pepper-flash

After typing in my password, this worked. Now

sudo apt-get update

I didn't need to type in my password, as I continued on the same terminal, but got W:/ and E:/ fetch file errors

sudo apt-get install pepflashplugin-installer

I continued on the same terminal despite the fetch file errors... and they said pepflashplugin-installer could not be found.

Is the last error because of fetch file errors, or because I need to download pepflash-plugin-installer somewhere? Or is it because of something else?

I cannot download the Chrome browser, and not looking to use flash player on my Firefox web browser (installed using lubuntu software center).

  • 13.04 is no longer supported, and, likely because of that, there are no packages for it in the PPA. – mikewhatever Feb 27 '14 at 23:00
  • @mikewhatever are you aware that this was asked in october, right? – Braiam Feb 28 '14 at 1:15
  • @Braiam Yep, though not sure why it matters now. Trying to apply the PPA solution doesn't work, and those that come here should know why, don't you think? – mikewhatever Feb 28 '14 at 9:00
  • Navigate to /etc/apt/sources.list.d folder then open pipelight*.list file with your text editor and replace raring with precise and run sudo apt-get update then run sudo apt-get install pepflashplugin-installer – kenn Feb 28 '14 at 10:52

Pepper Flash is now in Ubuntu repositories (14.04). Install it like:

sudo apt-get install pepperflashplugin-nonfree
sudo update-pepperflashplugin-nonfree --install
  • This should be accepted. – fosslinux Aug 2 '16 at 20:52

Now Pepper Flash plugin with the regular Flash has been moved to Ubuntu Partner repository.

Both Flash players can be installed by

sudo apt-get install adobe-flashplugin

after the Canonical Partner repository is enabled in Software & Updates.


If you installed Chrome Browser you don't need to install pepper-flash. You can use command line option redirecting pepper plugin path like

 chromium-browser --ppapi-flash-path=/opt/google/chrome/PepperFlash/libpepflashplayer.so --ppapi-flash-version=`grep -i version /opt/google/chrome/PepperFlash/manifest.json | awk '{print $2}' | awk -F"\"" '{print $2}'`

should work.

You can make a launcher script like


  chromium-browser --ppapi-flash-path=/opt/google/chrome/PepperFlash/libpepflashplayer.so --ppapi-flash-version=`grep -i version /opt/google/chrome/PepperFlash/manifest.json | awk '{print $2}' | awk -F"\"" '{print $2}'`

set execution bit

chmod +x chromium.sh
  • Get the following error: grep: /opt/google/chrome/PepperFlash/manifest.json: No such file or directory – Karl Morrison Dec 9 '14 at 0:32
  • @KarlMorrison You have to install chrome browser beforehand in order to use pepper plugin in chromium – kenn Dec 13 '14 at 16:24
  • @kenn i already have a chromium browser and i am also getting the same error – Eka May 27 '15 at 8:25
  • @Eka what is output of locate libpepflashplayer.so ? – kenn May 28 '15 at 14:21
  • 1
    @Eka then you don't have chrome web browser installed in your system. You need chrome's libpepflashplayer.so library file. The easiest way to have it is to install chrome browser. Difference between chrome and chromium is that chromium is open source while chrome is closed source. – kenn May 28 '15 at 15:57

Install the PPA from here: https://launchpad.net/~skunk/+archive/pepper-flash and use Chromium. A quick summary of the steps are:

sudo add-apt-repository ppa:skunk/pepper-flash
sudo apt-get update
sudo apt-get install pepflashplugin-installer

.. it then installs..

echo ". /usr/lib/pepflashplugin-installer/pepflashplayer.sh" | sudo tee -a /etc/chromium-browser/default

When you restart chromium, you should be using the new flash plugin!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.