I don't care if I mess up the system (which is likely if I do things like this), or the potential security issues that this could imply. Note, that I don't just want to "enable root login?", but run my GUI from bottom-up as root. I don't want to type my password for anything but just for login and have total control over it.

Of course, I want any application running as root, like Firefox, LibreOffice, etc. without having to mess up with the terminal. So, how do I do this?

This question tries to address users that do not like the current permission system with root being separated from normal users. I do not endorse such behaviors, but if a user wants to, for whatever reason, this question should fit their corncerns.

Not advisable for new users

  • 1
    I suggest s/new users/any users/. – guntbert Aug 15 '15 at 19:52
  • Root GUI can also be started from tty1 logged as root. See this post to start GUI from tty1. – user123456 Oct 22 '16 at 16:03
  • @PaulA. I don't think that you are commenting on the right question. – Braiam Jun 1 '19 at 5:40

Read this before doing anything Why is it bad to log in as root?

First of all, you must set root 's password.

sudo passwd root
Enter new UNIX password:

Now you have root password. Now activate the root account:

sudo usermod -U root

Then you should allow lightdm, gdm or kdm to allow logging in as root.

To enable this:


Edit /etc/gdm/custom.conf file and include AllowRoot=true.

Additionally, in newer versions of Ubuntu, you need to edit /etc/pam.d/gdm-password and comment out the line containing:

auth required pam_succeed_if.so user != root quiet_success

so that it looks like this:

#auth required pam_succeed_if.so user != root quiet_success


Edit /etc/kde4/kdm/kdmrc file and change AllowRootLogin=false for AllowRootLogin=true.

In LightDM

This procedure enables the "Other" menu, so you can type the username root and login. You must edit /etc/lightdm/lightdm.conf and add greeter-show-manual-login=true. Then reboot.

Others session managers have other methods to accomplish this.

As you have noticed I gave the instructions but by any circumstance you should not run the GUI as root. Murphy's Law says that it is likely that you mess up somehow and will be annoyed starting again.

I played around enough, how do I go back?

To disable root login just type:

sudo passwd -dl root

Then revert the changes on the files above. Did it feel good having super-cow powers?

| improve this answer | |
  • This was a very good summary. I wonder if someone can update it lateron to also include KDE5? – shevy Nov 3 '17 at 16:02

I've used nodm for this purpose on a LiveCD respin I had put together once upon a time.

sudo apt-get install nodm

Then configure it to enable and configure the user to use:

sudo vi /etc/default/nodm
| improve this answer | |
  • Link is broken. Maybe this is the same? (plus, I upvoted) – LogoS Oct 17 '17 at 14:57
  • Yes link may have changed so the one by LogoS is probably the right one these days. – shevy Nov 3 '17 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.