1

I have a Dell 17R SE with Ubuntu 13.04. The touchpad is recognized as PS/2 mouse out of the box, giving just normal touchpad behaviour, but no tap to click, no scrolling, etc.

Most answers related to that issue suggest trying an ALPS driver from dahetral.com: http://www.dahetral.com/public-download

For installing I followed the steps on this page: https://www.linuxwind.org/html/dell-touchpad-driver-for-ubuntu-13-04.html

Now my xinput looks like this:

Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Mouse                                id=13   [slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                  id=14   [slave  pointer  (2)]
⎜   ↳ Logitech Bluetooth Mouse M555b            id=16   [slave  pointer  (2)]

My touchpad isn't working at all now, just the two hardware buttons for left and right mouse buttons work.

Interestingly also the tap to click functions works, but only in the address bar of nautilus, nowhere (!) else.

What can I do? I would even switch back to initial state, where at least the basic touchpad functionality worked, i I knew, how to get there.

1

Try sudo modprobe psmouse i was able to get my touchpad working following this guide.

It look a lot like the one you followed except for that last command. My touchpad also stopped working before i issued that last command.

I hope it helps :-)

p.s. I have the same computer as you do an Insiron 17 R SE

|improve this answer|||||
1

Thanks for your help!

In the meantime I solved that issue by installing this selfpacked dell driver https://dl.dropbox.com/u/4427090/penzoditutto/glidepoint_3.6-13_amd64.deb, I found in this thread:

Alps Touchpad on Dell: how do I install the DKMS driver to enable multitouch?

It works like a charm on my machine. Multitouch gestures, scrolling, everything works now.

With your answer, people with Dell laptops now might find two working solutions in this thread for that touchpad problem.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.