Because i could not get the WiFi login work, i thought i will reinstall ubuntu, with internet connection to have updated drivers for wireless & graphics etc.

I have deleted earlier linux partitions usings gparted and re-installed ubuntu 13.10, exactly following the same steps as i did earlier, making a 100GB /home on dev/sda and pointing root to /dev/sdb (SSD) and swap on dev/sda/ . Installing boot on /dev/sdb.

But, somehow i think the grub is either corrupted or removed because i am unable to boot the laptop to any OS now.

I get the following message: "no such device" xxxxx followed by huge HEX number GRUB rescue>

when i type ls on Grub rescue> prompt, i can see hd0 & hd1, but thats about it. i tried Boot-repair but it is unable to fix the problem. The following log is generated via boot-repair create log:

Boot-repair log

I am unable to boot into windows or linux at the moment and need help to fix the grub so i can boot !!


So, i have tried Boot-Repair again, but this time in a different way. I downloaded the bootable boot-repair iso and made a usb disk. Then boot into it, connect to internet and start "Recommended Repair".

This time, it took me through a series of steps, asked me to manually delete/uninstall grub and then re-install a new version on sda & sdb. After the repair. i could successfully have a dual boot setup, without loosing any data !! This was AWESOME.. thanks to the easy tool "boot-repair"

In case anyone has a similar issue, i would recommend them to try boot-repair first and then look for an alternate solution. Again, like in my case, it is better to have a bootable boot-repair usb rather than running it from bootable ubuntu disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.