Sorry if I am a bit verbose but I am trying to recollect and provide as much information. Everything was working fine in 13.04 and I could even play dota2 on steam. Since upgrading to 13.10 it has been a nightmare.

Radeon 7770 card gives a black screen of death when loading Ubuntu. I am unable to get to a tty screen using the Radeon 7770 card and I have tried multiple kernels.

Therefore, I was forced to used the inbuilt motherboard graphics card. On first load, there was lots of error and Ubuntu had to run in low-res mode or some error like that appeared since the drivers installed was AMD catalyst and fglrx. I removed them but I think it is incomplete and installed Xorg files. So now, at least my Ubuntu starts up flawlessly if I used the inbuilt motherboard graphics with no errors at all.

I have tried changing lightdm to gdm, adding sleep, trying nomodeset, etc everything but it always still get stuck at the load screen without ability to tty if I use my Radeon card.

I am trying to install back my Radeon 7770 card now and install the drivers for it. Since I cannot slot in the card and have the computer detect it and then install the drivers, I am trying to manually install the drivers before I slot in the card.

I should have fglrx removed since there is no more fglrxinfo command. I have removed all the extra ppas (I tried oibaf, etc before) from software updates.

Right now, I have downloaded the latest AMD drivers and done a

sudo sh amd-driver-installer-catalyst-13-4-x86.x86_64.run --buildpkg

command and the deb files generate properly. But when I try to run

sudo dpkg -i fglrx*.deb

I get this error

Unpacking fglrx (from fglrx_13.250-0ubuntu1_amd64.deb) ...
One or more files have been altered since installation.
Uninstall will not be completed. See /etc/ati/fglrx-uninstall.log for details.
dpkg: error processing fglrx_13.250-0ubuntu1_amd64.deb (--install):
 subprocess new pre-installation script returned error exit status 1
Preparing to replace fglrx-amdcccle 2:13.200-0ubuntu1 (using fglrx-amdcccle_13.250-0ubuntu1_amd64.deb) ...
Unpacking replacement fglrx-amdcccle ...
Preparing to replace fglrx-dev 2:13.200-0ubuntu1 (using fglrx-dev_13.250-0ubuntu1_amd64.deb) ...
Unpacking replacement fglrx-dev ...
dpkg: dependency problems prevent configuration of fglrx-amdcccle:
 fglrx-amdcccle depends on fglrx; however:
  Package fglrx is not installed.

dpkg: error processing fglrx-amdcccle (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of fglrx-dev:
 fglrx-dev depends on fglrx; however:
  Package fglrx is not installed.

dpkg: error processing fglrx-dev (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

I have tried going to synaptic to fix the broken packages to no avail.

If I try to purge fglrx now I get this error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package fglrx_13.250-0ubuntu1_amd64.deb
E: Couldn't find any package by regex 'fglrx_13.250-0ubuntu1_amd64.deb'
E: Unable to locate package fglrx-amdcccle_13.250-0ubuntu1_amd64.deb
E: Couldn't find any package by regex 'fglrx-amdcccle_13.250-0ubuntu1_amd64.deb'
E: Unable to locate package fglrx-dev_13.250-0ubuntu1_amd64.deb
E: Couldn't find any package by regex 'fglrx-dev_13.250-0ubuntu1_amd64.deb'
E: Unable to locate package fglrx-installer_13.250-0ubuntu1_amd64.changes
E: Couldn't find any package by regex 'fglrx-installer_13.250-0ubuntu1_amd64.changes'

I have also tried looking into the dpkg status file as advised in one post to look for fglrx stuff and remove the lines containing it but I haven't been able to find any.

Can someone tell me perhaps the best way to figure out what graphic drivers I have installed since I might have messed up buy overinstalling and how to reset it to a blank state.

My inbuilt graphics works fine so 13.10 is stable is just that I can't use the 7770 with it! Am thinking of installing windows after all this frustration.



OK I think I have partially solved the issue so if anyone is experiencing the same problems as me this might help.

The issue is that the drivers either work for my onboard card or my Radeon 7770 card.

Originally upgrading to 13.10 broke, so it was easier to fix the onboard card drivers first so that I can attempt to get to a terminal. After that, I been trying to fix the Radeon 7770 card.

What I did from the last portion is to

sudo sh /usr/share/ati/fglrx-uninstall.sh -- force

This caused the onboard graphics card to break. I would load into a black screen with just my X cursor.

However, when I inserted my Radeon 7770 card now, it would at least also get me to the black screen with the X cursor. Which is positive! (weirdly enough). So now I could tty in with the Radeon Card installed. I went to the deb files and could do a

sudo dpkg -i fglrx*.deb

I also reinstalled the unity desktop.

On reboot, I could see the screen now with my Radeon 7770! There is still lots of errors popping up and I have to scale the screen but seems positive.

Edit Two

So I have been trying to install Steam after getting the Radeon 7770 card to work. Word of caution is changing the drivers in the Software and Updates section to fglrx-updates fails badly.

  • 1
    Yep, I found the same thing with 13.10 + HD7770. Catalyst won't install because it can't compile itself against the new kernel or libraries. – Ash Oct 31 '13 at 8:19

To make the Catalyst driver work, you need to use the 13.11 beta version.

The 13.4 won't compile with the Saucy's kernel according to the dependable @Nathan.

Check out this guide to see the whole procedure and several advices.


Been going round in circles with my 4870


sudo update-pciids

pulls in the new pci ids and run under the open mesa drivers as amd haven't updated since Ubuntu 12.10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.