0

I'm new to Ubuntu and have been using it for a couple of weeks now. Recently I encountered a problem where in I had to display a particular data on to a file. Here is the output displayed on the terminal.

  Potential vulnerability found (CVE-2009-4028)
  CVSS Score is 6.8
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2009-4030)
  CVSS Score is 4.4
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2009-5026)
  CVSS Score is 6.8
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0075)
  CVSS Score is 1.7
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0087)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0101)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0102)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0112)
  CVSS Score is 3.5
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0113)
  CVSS Score is 5.5
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0114)
  CVSS Score is 3.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0115)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0116)
  CVSS Score is 4.9
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0118)
  CVSS Score is 4.9
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0119)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0120)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0484)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0485)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0490)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0492)
  CVSS Score is 2.1
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0540)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

  Potential vulnerability found (CVE-2012-0553)
  CVSS Score is 7.5
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2012-0574)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2012-0583)
  CVSS Score is 4.0
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

 Potential vulnerability found (CVE-2013-1492)
  CVSS Score is 7.5
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

  Potential vulnerability found (CVE-2013-1506)
  CVSS Score is 2.8
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

Potential vulnerability found (CVE-2013-1521)
  CVSS Score is 6.5
  Full vulnerability match (incl. edition/language)
File "/usr/sbin/mysqld" (CPE = cpe:/a:mysql:mysql:5.1:::) on host glynis-desktop (key glynis-desktop)

I intend to display the Potential vulnerability found field and the corresponding score alone. There seems to be about 9995 entries and I would like to display all of them.

I have been using this command as of now

awk '/CVSS Score is/ < /Potential vulnerability found/' output.txt 

but this seems to display only the name of the vulnerability or the score. How do I display this in file(text,excel) such that all the vulnerability and the corresponding score willbe displayed.

Any help would be appreciated Thank you.

0

You can use grep:

grep -E "Potential vulnerability found|CVSS Score is" input_file

If you want to save the output in a text file, then use:

grep -E "Potential vulnerability found|CVSS Score is" input_file > output_file

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.