I had to reinstall Ubuntu and always used Guake Terminal and it was always starting when the desktop appeared and I only pressed F12 and it did everything I had to.

But now it doesn't start automatically. I was looking for an answer but nothing worked. Has anybody ideas how to solve it ? It would be really nice to use it as earlier ;)

Goto System -> Preferences -> Startup Applications.

or

Dash -> Type: Startup Applications

The Startup Application Preferences window opens. Then, click in Add, give a name for the application in the Name field ("Guake" it's enough), and then type “guake” without quotes in the Command field and click Add. Then close the Startup Application Preferences window and restart the machine, now Guake should start automatically on login.

source

  • Guake can be found here: /usr/bin/guake (if needed), else just type it like Chechus said ;-) – TungstenX Oct 15 '15 at 13:55
  • This worked nicely for me on 16.04. – JamesBB Apr 15 '17 at 11:17

have you tried adding it to the startup applications (search "startup applications")

If you have, try adding a .desktop file to /etc/xdg/autostart/

You can do this with the following command

sudo ln -s /usr/share/applications/guake.desktop /etc/xdg/autostart/

This is just an example, I don't know what the guake .desktop file is named but you can easily find out by having a look in the map: /usr/share/applications/

If by chance that doesn't work as well then there is one other solution you could try adding the following command to the startup applications

bash -c "sleep 10 && guake"

if it doesn't work try varying the sleep time because it depends on your system's speed but usually 10 seconds will work just fine

I hope this helps

  • I tried it with the Startup Applications and it didn't work earlier, the same now. But adding the desktop file solved the problem ! ;) Thanks very much ! – Karim Oct 30 '13 at 21:47

Use this:

sudo cp /usr/share/applications/guake.desktop /etc/xdg/autostart/

This helps for me:

Guake Doesn't Start When Session Starts

In Guake's preferences just uncheck Enable notifications on startup, and add the full path (e.g. `/usr/bin/guake) to startup applications.

locate guake.desktop then do,

$ cp /usr/share/applications/guake.desktop ~/.config/autostart/
$ echo "X-GNOME-Autostart-enabled=true" >> guake.desktop

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.