1

I've been setting up my Ubuntu (on a Macbook Pro, 64 bit), and I've run into a bit of a snag with wireless.

The first time I started up Ubuntu, the first thing I did was connect to my router via ethernet and run the following commands to install the drivers for my wireless card. These commands are

sudo apt-add-repository ppa:mpodroid/mactel
sudo apt-get update
sudo apt-get install b43-fwcutter firmware-b43-installer

I then ran added the line

blacklist ndiswrapper

to /etc/modprobe.d/blacklist.conf

and then created the file /etc/pm/config.d/modules, editing it to include

SUSPEND_MODULES="b43 bcma"

I then rebooted. I've actually installed Ubuntu on this very computer five or six times now, so this is almost standard procedure for me.

Anyways, I clicked on the wireless pop-up in the top-right corner. None of the networks showed up. Suspicious, I clicked "connect to a hidden network," entered my network's name and password, and what do you know? I was able to connect to my home network. The other local networks also showed up in the drop-down menu.

When I restarted later however, none of the networks showed up. I went to "connect to a hidden network" again, chose the right profile, and I was able to connect. Again, the other local networks showed up.

I figured that it was just a temporary problem- I set the settings to autoconnect to my home network. When I rebooted the next time however the same problem occurred, even though the "connect on startup" box in the home network was still checked.

The network can't be hidden, as I can connect to it using Windows 8, Windows 7, Mac OSX, and they've all recognized it without me having to manually input the network name.

I'm baffled here. Any help?

  • 1
    Baffling indeed. FTR, there are a number of duplicate questions (such as here, here and here), but none have an accepted answer. Have you tried installing without the mactel PPA? MBP models differ a lot, but raring and saucy work fine on my 6,2 with just the default repo's and settings. – zwets Oct 30 '13 at 21:00
  • What is your wireless device from the command: lspci -nn -d 14e4: – chili555 Oct 31 '13 at 12:25
  • Here's the output 02:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM57765 Gigabit Ethernet PCIe [14e4:16b4] (rev 10) 02:00.1 SD Host controller [0805]: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader [14e4:16bc] (rev 10) 03:00.0 Network controller [0280]: Broadcom Corporation BCM4331 802.11a/b/g/n [14e4:4331] (rev 02) – pipsqueaker Oct 31 '13 at 20:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.