3

I installed Ubuntu 13.04 alongside Windows 8 but when I want to access Windows drives I see this error massage:

Error mounting /dev/sda1 at /media/xalid/3A56A42656A3E0BD: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda1" "/media/xalid/3A56A42656A3E0BD"' exited with non-zero exit status 14: Windows is hibernated, refused to mount.
Failed to mount '/dev/sda1': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.

As a workaround I tried this:

mkdir /media/sd4
mount -t ntfs-3g -o ro /dev/sda1 /media/sd4

This allows me to access the partition, but I am unable to change anything on the drive since it was mounted as read only.

How can I access to my Windows drives whenever I login to Ubuntu?

2

Windows 8, by default, hibernates instead of fully shutting down (read: to allow for fast boot). It's a pain but I believe if you tell windows to reboot into the special "Advanced Options" mode in the settings then you could potentially tell windows to shutdown fully. Check out this link to shut down your windows 8 pc fully (link to another question click here for their tutorial they found to disable fast boot).

Running the command mount -t ntfs-3g -o ro /dev/sda1 /media/sd4 makes it read only hence the ro. Change that command to mount -t ntfs-3g -o rw /dev/sda1 /media/sd4 for writing.

  • I recognized the fact that Windows was hibernating, thus the inaccessible partition, but I didn't know Windows 8 automatically hibernates. +1 for that and the solution. – RPiAwesomeness Oct 30 '13 at 17:14
  • @RPiAwesomeness Yeah, my girlfriend has Windows 8. Fast boot is a great feature but it comes at the cost of making the PC mostly usable for Windows only. – Cole Busby Oct 30 '13 at 17:20
  • @RPiAwesomeness In order to keep from being to chatty, I'm just going to say that it's the user's preference. If the user enjoys the experience then so be it. I hated unity for the same reasons as some hate 8. It's a crapshoot either way. Ultimately, Fast Boot makes up for the Linux Pro of being able to load in 5 seconds from a complete shutdown. – Cole Busby Oct 30 '13 at 17:57
0

If you have exited windows it would normally automatically hibernate, despite setting it to shut down completely. That's windows for you.

So when you try to mount the windows partition in Ubuntu, it spots that it is hibernated and can't mount it.

I've found a workaround for this:

sudo mount -t ntfs-3g -o remove_hiberfile /dev/sda4 /media/1830838530836898_

{Replacing the /media/18308etc with your own drive.}

Enter password.

I get a few moans and groans in error messages but can then click on the windows partition in Nautilus and see its contents.

Try that.

It's not perfect but I don't have to worry about shutting down windows properly, which isn't as easy as it should be.

  • Is this safe? I mean, Ubuntu automatically not mounting the windows partition is probably done for a reason. – RPiAwesomeness Oct 30 '13 at 17:28
  • I have to agree, we are talking about windows afterall. This could potentially (not confirmed) wreck the boot for windows in case it checks for that after reading that it was shutdown with fast boot enabled. Chances are that you could be doing something really destructive here without realizing it? – Cole Busby Oct 30 '13 at 17:53
0

I had the same error in my ubuntu desktop while accessing windows folder. what i did was, go to DISK folder, in that you will see all the partition for linux and windows.click onto windows partition, go to setting and choose Mount option. In that just tick the line which say mount at the beginning of booting your desktop. After this you can now access your windows file in ubuntu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.