I have a problem with my network adapter after upgrading from 13.04 to 13.10. The adapter works for literally several seconds after I establish the connection but then it looks as if it got clogged somehow.

This is what I see amongst my devices:

~$ lspci | grep -i wireless
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
~$ uname -a
Linux bubek 3.11.0-12-generic #19-Ubuntu SMP Wed Oct 9 16:12:00 UTC 2013 i686 i686 i686 GNU/Linux
~$ lsmod | grep 80211
lib80211_crypt_tkip    17387  0 
lib80211               14040  2 wl,lib80211_crypt_tkip
cfg80211              401436  1 wl

Now, how does is behave. Let's assume I connect to my wireless network and straight after I get connected I ping the default gw:

~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=64 time=226 ms
64 bytes from icmp_seq=4 ttl=64 time=222 ms
64 bytes from icmp_seq=7 ttl=64 time=260 ms
64 bytes from icmp_seq=11 ttl=64 time=265 ms
64 bytes from icmp_seq=16 ttl=64 time=117 ms
From icmp_seq=45 Destination Host Unreachable
From icmp_seq=46 Destination Host Unreachable

What has happened over here? Is there any possibility I can get it working? The only way I could write that post was that I used my phone and USB tethering :)

Thanks for any tips in advance!


Please try:

sudo apt-get purge bcmwl-kernel-source
sudo modprobe -rv wl
sudo modprobe -v brcmsmac

if there are any errors please continue with the commands then reboot. your wireless should be working now.

  • Thank you. This solved my problems with BCM4313 wireless on an Asus laptop after I updated it to Ubuntu 13.10 and the wireless stopped working with some hotspots (newer ones, I assume, as it worked with an old wrt54). – wojci Mar 17 '14 at 19:52

First of all, check your current driver. You can do this by typing sudo lshw > hw_info in a terminal.

Scroll to Wireless interface. It should show your current driver and the version used.

            description: Wireless interface
            product: BCM4313 802.11bgn Wireless Network Adapter
            vendor: Broadcom Corporation
            physical id: 0
            bus info: pci@0000:25:00.0
            logical name: eth1
            version: 01
            serial: ec:55:f9:2a:d3:58
            width: 64 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
            configuration: broadcast=yes driver=wl0 driverversion= ip= latency=0 multicast=yes wireless=IEEE 802.11
            resources: irq:19 memory:d4000000-d4003fff

You can see from the last line, that I am using wl0 driver version

There are several drivers to choose from (Official Documentation). You can switch to brcmsmac or use the 5.100 version of wl0 which has so far worked without any problems by following these instructions.

  • Also, you should probably report this as a bug in launchpad so that it can be fixed. – Eero Aaltonen Oct 30 '13 at 13:17

protected by Community Apr 30 '14 at 22:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.