3

I've recently upgraded to Ubuntu 13.10 which has a known bug that makes it impossible to change keyboard layout via Alt+Shift. I installed this patch which made it possible to switch layouts again.

The problem I'm facing now is that it is still impossible to switch keyboard layout when I lock (Ctrl+Alt+L) system and press Alt+Shift. This way if I lock system with wrong layout enabled, I can't switch it to enter the password and unlock PC. I can still change layout by clicking on the layout indicator. I'll be thankful for suggestions on solving this.

I'm aware that this is due to a bug, but how can I work around this bug in the meantime?

2

The bug has been reported here

https://bugs.launchpad.net/ubuntu/+source/gnome-screensaver/+bug/1244548

and, as you said, it is only possible to change layout by clicking the layout indicator.

No workaround is known so far, so the only thing you can do is to wait until a fix is released. The importance of this bug is set to medium, so it may take a while. If you want to speed up the process, you may register on launchpad (if you are not registered yet) and state that the bug also affects you (it increases the bug heat by 4 points per affected user). Also, you may subscribe to notifications from launchpad, so that you receive an email when the bug is closed (they also increase the bug heat by 2 points per subscriber).

  • 2
    I stated in Launchpad that the bug affected me and hope that it helps the bug to be solved faster! – PHP Learner Feb 15 '14 at 13:08
2

There is workaround. if you want to use only control keys combination like ctrl+shift or shift+alt to switch between sources you could set "Switch to next source using" to only control keys combination like shift+alt while set "Switch to previous source using" to your combination + space and use it only in case of the lock screen.

  • Unfortunately, I can't test this answer, as I've long ago switched to OS X, but if someone confirms, I'll accept it. – svz Dec 21 '15 at 7:02
0

With a simple click in the language indicator of the unlock window, the current selected language is changing and then I can type the password!

0

This worked for me (I'm going to type exactly what I did and this is easiest method I could explain -don't ask why :| ) :

  1. Click on "Text Entry Settings..." under EN language icon (or whatever else if it's not your chosen language)
  2. in 'Switch to next source using' >> PRESS "Shift R" then PRESS "Alt + Shift R" >> text inside this section should be "Shift+Level3 Shift" !
  3. in 'Switch to previous source using' >> PRESS "Alt + Shift R" >> text inside this section should be "Alt + Shift R".

This is weird but worked for me. I tried it on Ubuntu 16.04 LTS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.