26

The Error reads:

Your profile could not be opened correctly. Some features may be unavailable. Please check that the profile exists and you have permission to read and write its contents.

I have checked for a fix but they involve resetting Chromium and losing all my Bookmarks. I believe it is a sync problem. Is there a way to fix it?

5

Got this error before. What I did was try to sync again using the same username (not reset sync). From what I experienced, the bookmarks and apps still exist, and it will update the sync with your current account.

Any way, based on google groups from user meyertree you can do this to backup your bookmarks to prevent data lost:

  • Go to Chrome settings and choose "Disconnect Your Google Account"
  • Go to the Google Dashboard: https://www.google.com/dashboard/
  • Under "Chrome Sync" choose to reset sync and delete all data
  • Close Chrome
  • Copy the bookmark file from the backup and overwrite the current bookmark file
  • Open Chrome - your bookmarks should be back
  • You can sign in to Chrome sync again. Because the sync data was reset, the new bookmarks will be synced
  • 1
    Thanks, guy! The answer I received popped up elsewhere and the answer was to revert to the chromium_old comfig file. I'll share the info elsewhere. – Diogenes Lantern Oct 30 '13 at 14:00
  • 1
    Far more complicated than Qeremy's answer which works. – Wtower Dec 6 '14 at 16:21
31

Simply use

rm -r ~/.config/google-chrome/Default/Web\ Data

or (on Ubuntu 14.10)

rm -r ~/.config/chromium/Default/Web\ Data

or, for the lazy,

l ~/.config/google-chrome/Default/Web\ Data
l ~/.config/chromium/Default/Web\ Data
rm -rf ~/.config/google-chrome/Default/Web\ Data
rm -rf ~/.config/chromium/Default/Web\ Data

* Be careful while using rm -rf

UPDATE

I am really sick of seeing this error and I did this;

Make a file

nano ~/delete-chrome-web-data

Put this in it

#!/usr/bin/env bash
rm -rf ~/.config/chromium/Default/Web\ Data
rm -rf ~/.config/google-chrome/Default/Web\ Data

give the script execute permission

chmod u+x delete-chrome-web-data 

And when I see that error, run: sh ~/delete-chrome-web-data

  • 2
    1) If you're using chromium, substitute "chromium" for "google-chrome" above. – Reece Sep 28 '14 at 16:28
  • Also worked for me. Chromium Version 37.0.2062.120 Ubuntu 14.04 (281580) (64-bit). Be sure to substitute "chromium" for "google-chrome" in the path if appropriate. I exited chromium first via chromium menu in unity top panel. Other solutions in this thread were not required. – Reece Sep 28 '14 at 16:38
  • Worked for me, but the next time I logged into my computer and opened Chrome, the error message appeared again. – Seppo Enarvi Feb 2 '15 at 11:28
  • Is this means we'll lose all the data? or will it download cloud synced data after signed in again? – armanke13 Feb 27 '16 at 5:27
  • 1
    Whenever I intend to issue an rm -rf command anywhere on any system, I always omit the -rf until after the path, to never accidentally pinky the enter key instead of shift and needing to print a resume shortly thereafter. – Hydranix Aug 19 '17 at 23:12
16

Short term fix is to run sudo killall chrome twice.

$ sudo killall chrome
$ sudo killall chrome

After this Chrome will start normally.

A long term fix would be to enable in chrome://settings/ Show advanced settings ... and check "Continue to run background apps when Google Chrome is closed" will fix the problem.

It appears to be problem with Chrome or one of his extensions not being closed properly.

  • @Mike why twice? – nutty about natty Sep 15 '15 at 8:32
  • 3
    This is the best solution! – Michael Z Nov 5 '15 at 10:56
  • I don't know why this worked.... but it worked. – justderb Mar 7 '16 at 23:53
  • This is the best solution – Allen Jan 15 '18 at 13:15
3

chmod -R 775 ~/.cache/chromium && chmod -R 775 ~/.config/chromium is what got everything to roll for my end.

EDITED: added ~/.config/chromium to the original answer.

1

In fact I had to use the first part of your solution to answer my problem.

Go to Chrome settings and choose "Disconnect Your Google Account"

Go to the Google Dashboard: https://www.google.com/dashboard/

Close Chromium and restart. Go to "customize and control Chromium in the top right.

Click sign in to Chromium. Enter your account information.

One thing more, NOW I have a file on my desktop holding my chromium backup.

  • This worked with Google Chrome, though I don't understand why I would have a backup file on my desktop. – Seppo Enarvi Feb 25 '15 at 0:05
0

Possibly related bug report: http://crbug.com/449740

It mentions some trouble when interacting with gnome-keyring, and suggests running google-chrome --password-store=basic (this is insecure, please use it only for this testing).

It also mentions that a Chrome version downgrade may cause it: In general, this message will be seen if we Over install from higher version to lower.

0

To get rid of this error, delete both Web\ Data* and History*.

The complete set of comands are:

cd .config/google-chrome/Default/ rm -rf Web\ Data* rm -rf History*

Done!

protected by Community Oct 10 '14 at 8:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.