I'm having a very hard time getting webex to work under Saucy. Up until now I've been able to just install a java plugin, install ia32-libs, and I was good to go. With Saucy ia32-libs is gone and it's up to us to figure out which 32-bit libraries we need to install.

So the question is, how do I install WebEx on 64bit Saucy without ia32-libs?

  • sudo update-alternatives --set "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" "mozilla-javaplugin.so" does'n't work, but I think it should be the other way around sudo update-alternatives --set "mozilla-javaplugin.so" "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so, if I understand the update-alternatives syntax right.
    – user263807
    Mar 31, 2014 at 7:52
  • Did it like cdupont, but if I start firefox I get this error-messages ./firefox XPCOMGlueLoad error for file /home/paulsen/firefox32/firefox/libxul.so: libXt.so.6: cannot open shared object file: No such file or directory Couldn't load XPCOM.
    – user263812
    Mar 31, 2014 at 8:00
  • I was able to get it working in 2 steps with minimal fuss: askubuntu.com/a/363400/18665
    – bmaupin
    Sep 5, 2014 at 15:35

6 Answers 6


From this post, here is a step-by-step method that might work:

  1. Install JDK.
  2. Configure Java plugin for browser (no need for a 32-bit JDK or Firefox).
  3. Start a WebEx to create .so files inside $HOME/.webex/????/.
  4. Check for unresolved .so dependencies:
    ldd $HOME/.webex/????/*.so > $HOME/check.txt
  5. Search for missing libraries:
    grep "not found" $HOME/check.txt | sort | uniq
  6. Review the libraries; for example:
    libasound.so.2 => not found
    libjawt.so => not found
    libXmu.so.6 => not found
    libXtst.so.6 => not found
    libXv.so.1 => not found
  7. Find the corresponding packages:
    sudo apt-get install apt-file
    sudo apt-file update
  8. Locate that package that contains the missing libraries:
    apt-file search libXmu.so.6
    apt-file search libjawt.so
  9. Install the missing libraries, for example:
    sudo apt-get install -y libxmu6:i386
    sudo apt-get install -y libasound2:i386
    sudo apt-get install -y libxv1:i386
    sudo apt-get install -y libxtst6:i386
    sudo apt-get install -y libgcj12-awt:i386
  • Can you confirm that you get a lot of these errors in your console: java.lang.UnsatisfiedLinkError: .../.webex/1324/libdbr.so: wrong ELF class: ELFCLASS32? Apr 7, 2014 at 8:31
  • This worked appears to have worked for me based on test webinar sudo apt-get install libXmu6:i386 libgcj14-awt:i386 libXft2:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 A few extra packages were also automatically installed: libgcj14:i386 libgmp10:i386 Sep 3, 2014 at 16:52
  • In Ubuntu 16.04 I was missing these: sudo apt-get install libgtk2.0-0:i386 libgcj16-awt:i386 libpango-1.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libxft2:i386 libxmu6:i386 libxtst6:i386 Oct 28, 2016 at 7:53
  • I don't find anything with grep "not found" $HOME/check.txt | sort | uniq. I found "not a dynamic executable" warnings about a number of libraries, so I used grep "\.so" /tmp/check.txt | sort | uniq | sed 's/.*\/\(.*\):/\1/g' and it yields atascli.so atgzip.so atjpeg.so atpng.so libatdv.so libAudioEngine.so libcmcrypto_jni.so libdbr.so libgdiplus.so libmmaud.so libmmsvid.so libmsess.so libtpwrap.so libwbxtrace.so libwelsvp.so welsdec.so and apt-file search is only able to find libgdiplus (already installed), i.e. most of the others are still missing. :\ Any suggestions? Feb 23, 2017 at 10:30

Here are the complete instructions for my future self and those interested. The solution is to install firefox 32 bits with Oracle Java 32 bits.

First get firefox 32 bits:

wget http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/latest/linux-i686/en-US/firefox-27.0.1.tar.bz2
bunzip2 firefox-27.0.1.tar.bz2
tar -xvf firefox-27.0.1.tar

Then get Oracle java 32 bits (replace download with latest version):

wget --no-cookies --header "Cookie: gpw_e24=http%3A%2F%2Fwww.oracle.com" "http://download.oracle.com/otn-pub/java/jdk/7u51-b13/jre-7u51-linux-i586.tar.gz"
tar -xzvf jre-7u51-linux-i586.tar.gz
mkdir /usr/local/java
sudo mv jre1.7.0_51 /usr/local/java

Create and activate the alternative for the java plugin into firefox:

sudo update-alternatives --install "/usr/lib/mozilla/plugins/libjavaplugin.so" "mozilla-javaplugin.so" "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" 1
sudo update-alternatives --set "mozilla-javaplugin.so" "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" 

Shut down all instances of Firefox if already running, and start 32 bits firefox:

cd ~/firefox

To check the version of java, type about:plugins in the address bar. It should display:

Java(TM) Plug-in 10.51.2
File: libnpjp2.so
Path: /usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so
Version: 10.51.2
State: Enabled
Next Generation Java Plug-in 10.51.2 for Mozilla browsers

Note that when you are done with Webex, you can change back your version of the java plugin to the 64 bit version (if it was installed) by typing:

sudo update-alternatives --config "mozilla-javaplugin.so"

And selecting the correct entry.

Additionally, it is necessary to install missing webex libraries as described in Russ Lowenthal's answer:

cd ~/.webex
ldd *.so | grep "not found"
#get the package containing the missing libraries (example libXtst.so.6):
dpkg -S libXtst.so.6
#install the corresponding package (appending i386 for the 32bits version)
sudo apt-get install libxtst6:i386

Tested also on a fresh install of Ubuntu 14.04 Trusty Tahr, it works. Let me know if you have problems.

  • how functional is Webex under 32-bit FF? can you share your desktop?
    – Kendor
    Mar 31, 2014 at 17:18
  • Yes you can share your desktop, eveything works fine. The sound is perfect, the only problem is that from time to time the java VM and pulseaudio take 100% of their CPU and then the sound gets inaudible. I didn't found a definitive solution yet, but usually closing some applications, restarting the sound or stoping the screen share solves the problem.
    – cdupont
    Apr 1, 2014 at 17:49
  • Gave this a whirl, but got stuck on the alternative plugin setup... the first command works, but the second doesn't: me@X230:~$ sudo update-alternatives --set "/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so" "mozilla-javaplugin.so" update-alternatives: error: alternative name (/usr/local/java/jre1.7.0_51/lib/i386/libnpjp2.so) must not contain '/' and spaces
    – Kendor
    Apr 1, 2014 at 21:54
  • 1
    +1 Note: If you don't want to pollute /etc/alternatives (which isn't 32/64bit aware), you can put the plugin into a folder and set MOZ_PLUGIN_PATH. See askubuntu.com/questions/383960/… Apr 7, 2014 at 11:41
  • Kendor: corrected
    – cdupont
    May 23, 2014 at 11:41

ldd was not working for me and would return "not a dynamic executable" for the *.so files

~/.webex/1424$ ldd *.so
    not a dynamic executable
    not a dynamic executable
    not a dynamic executable
    not a dynamic executable

I had to install these 3 packages to get it to run (replacements for ia32-libs)


After that this command helped me find the packages I needed (can take a while)

$ for x in `ldd *.so | grep "not found" | sort -u | awk '{print $1}'` ; do apt-file search $x >> packages.txt ; done

If anyone gets here but doesn't find the .webex folder check the following:

Cannot start Webex session. Java permission issue?


Go to AWS, and create a Windows instance. Install Chrome and the Webex extensions. Make an image. Whenever you need webex, just spin up the instance.

TRUST ME, trying to get a 32bit app working with a 64bit box has caused me SO much trouble. I have wasted a good portion of my life trying, and the screen share is terrible even when I got it working. I Write to Webex once every few months and get nothing back. My Company has moved to Slack, which works perfectly on Ubuntu, good call quality and I can share my screen. However, we do have to interact with other, not as enlightened companies and webex is needed. It is SO worth the pennies per month it takes to get this to work.


The previous answer will do this as well, but I am a bit lazy, so I rebuilt the ia32-libs-multiarch package for Saucy and it works for me. All I did was change two dependencies for libglphoto-2 to the current version and repackage the raring package for multiarch.

It is available here, at my long-forgotten Word Press site. Don't write as a regular blogger that much primarily because work keeps me busy in Support. Besides, OrangeCrate is long dead because of the same reason. Work keeps me busy, and I credit learning Linux for that.

Anyway, have a nice day. Don't worry, be happy.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .