My Wacom tablet (CTH-480) is not detected by the Wacom Tablet option under settings. The Tablet shows up when I run lsusb but does not show up under settings. Again Thanks.

  • 1
    I have exactly the same problem (same device, same Ubuntu release) ... hopefully someone comes up with an answer soon!
    – lpdbw
    Nov 4, 2013 at 16:03
  • 1
    Hi Bradley can you set the answer below as correct? I just followed the instructions and is working smooth. I find fair that you give it as correct and other people can also enjoy
    – user42375
    Dec 1, 2013 at 10:29
  • Will it be supported in 14.04 out of the box?
    – student
    Dec 29, 2013 at 21:26
  • I tried a beta image of 14.04 now (2013-01-07). The tablet is not detected out of the box. I hope the driver will be pushed upstream before release... if someone knows where to ask for inclusion, please tell me and I will look into it.
    – Rmano
    Jan 7, 2014 at 17:27
  • I checked a beta of 14.04 on a virtualbox VM today, and using the "passthru" USB driver, the tablet has been detected automatically without the need of any additional driver. Unless the virtualbox layer is doing some strange thing, is a good news for 14.04!
    – Rmano
    Apr 1, 2014 at 22:33

2 Answers 2


Update for 14.04

Short (really) version. The tablet works out of the box, but sometime you need to manually load the driver with sudo modprobe wacom before attaching (or switching on if wireless) the tablet.

Nevertheless, the following instruction can be helpful if some new tablet comes out which has support in the upstream driver but not in the stock kernel.

Update for 13.10, 14 Dec 2013, input-wacom >= 0.20.0

Short version: you do not need to patch input-wacom anymore starting from version 0.20.0, and you do not strictly need to update the X.org input driver in 13.10.

Long version:

For 13.10, if you accept to forego the new things added to x86-input-wacom (at this time: 14 Dec 2013, looking at changelogs, it's some stuff about better touch behavior) you can simplify it a lot.

Basic information is still from the main answer, and from here, with a slight difference.

1) Download the last version of input-wacom kernel driver. It should be at least 0.20.0, otherwise the tablet will not be detected, from here: http://sourceforge.net/projects/linuxwacom/files/xf86-input-wacom/input-wacom/. In date 2013-12-14, the newest is input-wacom-0.20.0.tar.bz2.

2) be sure to have the build dependencies installed. Upgrade your system if you have not, so you have the last kernel. If it says that a reboot is needed, reboot before continuing (this is to avoid to build against a wrong kernel).

sudo apt-get install build-essential libX11-dev libxi-dev x11proto-input-dev xserver-xorg-dev libxrandr-dev libncurses5-dev autoconf libtool
sudo apt-get install linux-headers-generic

Notice that if uname -r tell you that you have a special kernel (ending not in -generic, but -rt, or -lowlatency, or whatever, you should modify the second apt-get accordingly)

2) uncompress the driver in a directory of your choice. Move the downloaded file in that direcory, cd to it, and

tar xjvf input-wacom-0.20.0.tar.bz2

3) a directory input-wacom-0.20.0 is created. cd to it and compile the drivers:

cd  input-wacom-0.20.0
./configure --prefix=/usr

Update In versions prior to 0.27 or whereabout, that started the compilation too. If using a newer one, you need to issue

 make   # only for versions >= 0.27.0

if there are no errors, at the end you have a message starting with:

       linux kernel - yes 3.7
      kernel source - yes /lib/modules/3.11.0-14-generic/build

Your wacom.ko is available under 
[...more stuff...]

You have kernel 3.11.something, not 3.7 --- do not worry. It's ok.

4) Install the driver. For versions < 0.27.0, you have to use:

sudo cp ./3.7/wacom.ko /lib/modules/`uname -r`/kernel/drivers/input/tablet/wacom.ko
sudo depmod -a

otherwise, for a more recent version, just do

sudo make install 

If you had not the tablet connected since the last reboot (i.e. you had no kernel module wacom.ko loaded), a reboot is not needed. You can just plug your tablet and go. Otherwise, reboot.

NOTICE: Every time the kernel is updated, you need to repeat step 3 and 4 (*)(you better add a

make clean 

in the driver directory before the ./configure step to rebuild all anew).

(*) you have to do the installation AFTER rebooting in the new kernel, because otherwise the uname -r tricks will install the module in the wrong place...

AND ANOTHER NOTICE: if you tablet works, but it does not show up in the control panel, look at this answer and

sudo apt-get install xserver-xorg-input-wacom
  • Works perfect, thanks! Just as a side question: can I move the directory input-wacom-0.20.0 afterwards or will this mess everything up? I did the whole procedure in the downloads directory but would like to move it to another place...
    – lpdbw
    Dec 19, 2013 at 14:28
  • 1
    You can move it wherever you want. When you have a kernel upgrade, cd to the directory, do make clean, and restart from point 3)
    – Rmano
    Dec 19, 2013 at 15:51
  • Off-topic question/side remark: I would like to remove the Wacom related entries in System Settings -> Software & Updates -> Other software because I think they cause these silly "update information outdated" messages I get all the time. Have these entries been added by the process described in your post? Can I delete them without harming the functionality of my tablet again?
    – lpdbw
    Dec 20, 2013 at 16:51
  • I really don't know what could be the problem. The procedure listed here does not modify any repository info --- uses just the stock packages for comiling things. The message you have is often caused by a PPA or something like that that went offline. Last time it happened to me was because of Medibuntu (which is no more).
    – Rmano
    Dec 20, 2013 at 16:59
  • 1
    OK, it does work now!?!
    – lpdbw
    Jan 7, 2014 at 9:55

The tablet is too fresh :-) the input-wacom developers are working on support in the upcoming release of input-wacom (kernel driver) and x86-input-wacom (xserver input driver) as soon as the patches are accepted into the kernel upstream, they will release the new version.

If you don't want to wait that long to get your new tablet going -- the solution is to compile the kernel-module and xserver-driver yourself - I have 12.04 running with 3.8.0-32-lowlatency kernel from the kxstudio ppa, so I don't know if this works with the stock 3.2 kernel but since you are on 13.10, that shouldn't be a problem. You have to follow the instructions on the linux-wacom website on how to compile the kernel module and the xserver driver almost to the letter but you have to apply three patches in the process. Be sure to install all the build-dependencies needed and mentioned on the linux-wacom website.

The gist of it is

 mkdir ~/wacom
 cd ~/wacom
 git clone git://git.code.sf.net/p/linuxwacom/xf86-input-wacom
 git clone git://git.code.sf.net/p/linuxwacom/input-wacom

Now you need two patches for the kernel module, posted by a wacom developer in this thead http://sourceforge.net/p/linuxwacom/mailman/message/31592023/ as attachments to this post http://sourceforge.net/p/linuxwacom/mailman/message/31599376/

  • 0001-Input-wacom-Not-all-multi-interface-devices-support-.patch
  • 0002-Input-wacom-add-support-for-three-new-Intuos-devices.patch

Apply them

cd input-wacom
patch -p1 < ~/Downloads/0001-Input-wacom-Not-all-multi-interface-devices-support-.patch
patch -p1 < ~/Downloads/0002-Input-wacom-add-support-for-three-new-Intuos-devices.patch

compile the module


then make a backup of the old module and install the freshly build

sudo cp /lib/modules/$(uname -r)/kernel/drivers/input/tablet/wacom.ko /lib/modules/$(uname -r)/kernel/drivers/input/tablet/wacom.ko.BAK
sudo cp 3.7/wacom.ko /lib/modules/$(uname -r)/kernel/drivers/input/tablet/wacom.ko
sudo depmod -a

To get a working xserver driver you have to apply a patch to get the git-sources to work with the ubuntu 12.04 xserver, the build_against_frankenserver.patch - the patch is available e.g. attachment in this thread http://ubuntuforums.org/showthread.php?t=1515562&page=104 , I don't know if this is still necessecary with 13.04 or 13.10! (and ignore patch failures in the test/ directory)

cd ../xf86-input-wacom
patch -p1 ~/Downloads/build_against_frankenserver.patch
./configure --prefix=/usr --libdir=/usr/lib

Install it

sudo cp /usr/lib/xorg/modules/input/wacom_drv.so /usr/lib/xorg/modules/input/wacom_drv.so.BAK
sudo cp src/.libs/wacom_drv.so /usr/lib/xorg/modules/input/wacom_drv.so

Reboot or restart and it should work.

Again be sure to read all the information given to you over at linux-wacom.sf.net, this is only a rough summary, and I wont have the time to help in depth anytime soon.

Still, I hope this helps -- the Intuos PTS is a really cool device, and it works like a charm this way.

  • Thank you for your response... was hoping for an easy fix... its a shame Wacom doesn't release drivers themselves same with other hardware manufacturers such as Nvidia, etc... darn my laptop isnt powerful enough to handle compiling something that large... it crashes if I compile simple java applications due to maxing out my little Pentium processor... Cant believe i just spent money on a tablet that isn't supported at this time... Again thanks for the feedback... going to leave this open as is still not "solved" Nov 6, 2013 at 20:40
  • 1
    Neither the module nor the driver are large - give it a go at the weekend. Regarding Wacom: I think they simply don't want to be legaly responsible to provide support for the 200 distros out there - as far as I know at least some of the linux-wacom developers and especially the project founder are/were wacom employees. The reason for the 'delay' ATM is that they, as a policy, release new versions only when the necessary kernel changes are accepted upstream by the kernel devs. But the patches provided by jason are a 'quick hack' as he writes that make further changes to the kernel unnecessary.
    – Tom Regner
    Nov 6, 2013 at 20:45
  • Do you mean that at a later time compatibility will come automatically with the regular Ubuntu updates? And what is the expected time when this will happen (weeks, months, ...)?
    – lpdbw
    Nov 14, 2013 at 13:32
  • That should indeed be the case -- possibly not via regular updates , but involving a ppa -- in a timeframe comprised of weeks AFAIK
    – Tom Regner
    Nov 14, 2013 at 13:50
  • 2
    @lpdbw : I added an answer. Hope it helps.
    – Rmano
    Dec 14, 2013 at 18:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .