0

After upgrading from 12.10 to 13.04 I get the following error when trying to open evolution's addressbook:

This address book cannot be opened.  Please check that the path /home/... exists and that permissions are set to access it.

Detailed error message: Cannot open book: table folders has 8 columns but 6 values were supplied

I installed 12.10 on another machine, copied ~/.local/share/evolution/ and ~/.config/evolution/ respectively to the new machine and still it couldn't even find the addressbook.

I would really appreciate if someone could free me of my misery!

3
  • Maybe you forgot to copy ~/.gconf/apps/evolution? – Izzy Oct 30 '13 at 21:34
  • Also tried that but with no success. – Yan Foto Nov 1 '13 at 9:40
  • Have you taken care for the Gnome settings daemon? As that folder is about this one, it might need a restart. See also my answer here – slightly different issue, but the details might prove helpful. – Izzy Nov 1 '13 at 12:57
0

When I upgraded from 13.04 (Evolution v3.6.4) to 13.10 (Evolution v3.8.4), I found 13.10 'broke' too many critical functions necessitating a downgrade back to 13.04. I had tar backups of the necessary Evolution folders (.local/share/evolution, .config/evolution, .config/dconf) as well as backups using Evolution's internal 'Backup Evolution data' option.

I chose to preserve the 'broken' 13.10 O/S until the downgrade was complete so I did a clean install of 13.04 in a separate partition, installed Evolution 3.6.4 and attempted to restore Evolution's internal backup (taken prior to the upgrade) using Evolution's 'first run' Startup Wizard. User accounts, email, calendar, tasks, and memos all restored correctly EXCEPT for the addressbook. After the Startup Wizard restore, the address book was empty and produced the same error you received ('table folders has 8 columns but 6 values were supplied').

I tried restoring a tar backup. It produced the same address book table error. I also tried exporting the ubuntu 13.10/Evolution 3.8.4 address book as a vcard (.vcf) file and importing into ubuntu 13.04/Evolution 3.6.4, also without success.

Finally, to confirm the address book even worked, I created one new record in the empty ubuntu 13.04/Evolution 3.6.4 address book. Evolution allowed me to create that one record. I again attempted to import the vcard list and this time the import was successful.

2
  • So you exported the broken addressbook, created a new empty in 13.04 addressbook and imported that addressbook you exported in 13.10? – Yan Foto Nov 3 '13 at 19:09
  • The 13.10 address book was good. The 'table folders has 8 columns ...' error did not occur in 13.10 and the address book worked correctly. The errors did not appear until attempting to import the 13.10 address book BACK into 13.04. – John Littleton Nov 4 '13 at 12:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.