14

I have done the following steps:

sudo add-apt-repository ppa:langdalepl/gvfs-mtp 
sudo apt-get update

and updated some packages from update manager. After doing above steps I am able to see lumia phone name in file system. But when I try to mount device I am getting following errors:

Unable to mount RM-914|Nokia Lumia 520
Unable to open MTP device '[usb:001,010]'

Is there any way to solve these problem?

6
  • Hm. Where did you get your instructions from?
    – fouric
    Commented Oct 29, 2013 at 15:43
  • webupd8.org/2013/01/upgrade-to-gvfs-with-mtp-support-in.html from above link...
    – pavankumar
    Commented Oct 30, 2013 at 14:15
  • Am I mistaken, or does that tutorial cover connecting to Android devices, while the Lumia is a Windows Phone device?
    – fouric
    Commented Oct 30, 2013 at 16:12
  • MTP is universal as I understand it. Commented Jan 19, 2014 at 4:40
  • have you solved the problem? how? i have this problem too Commented Jan 22, 2014 at 6:09

4 Answers 4

25

These are my steps to connect the Nokia Lumia 920 (WP8):

1. Add the MTP file system in Ubuntu:

sudo add-apt-repository ppa:langdalepl/gvfs-mtp 
sudo apt-get update

2. Make a new udev rule:

2.1 Create the rule file:

sudo nano /etc/udev/rules.d/69-libmtp.rules

2.2 Add the following line to the file:

ATTRS{idVendor}=="01b1", ATTRS{idProduct}=="01b1", SYMLINK+="libmtp", MODE="660", ENV{ID_MTP_DEVICE}="1"

2.3 Save the file (Ctrl+O)

3. Reload udev rules:

# udevadm control --reload-rules

4. Connect (or reconnect) the device.

4
  • 1
    Finally..! Saviour..!
    – Kishore
    Commented Aug 24, 2014 at 22:48
  • 5
    According to that PPA's page, "13.10 (Saucy) and newer versions of Ubuntu contain all of these changes, so you don't need to use this ppa any more." Unfortunately, even in 14.04 Windows phone won't mount due to this bug: bugs.launchpad.net/ubuntu/+source/gvfs/+bug/1247572 - If you notice this problem, you can select "this affects me" and get notices if/when this is fixed.
    – NoBugs
    Commented Sep 2, 2014 at 4:23
  • 2
    Awesome.. This really worked for Nokia lumnia 625..!
    – NiRUS
    Commented Dec 14, 2014 at 16:20
  • idVendor and idProduct are universal? since mines are different but I can connect my phone using this values
    – Yashar
    Commented Jun 2, 2016 at 11:47
3

Make a new udev rule

sudo emacs -nw /etc/udev/rules.d/69-libmtp.rules

And add the following line

ATTR{idVendor}=="01b1", ATTR{idProduct}=="01b1", SYMLINK+="libmtp",
MODE="660", GROUP="audio", ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1" 

You need to refresh the udev rules and unplug/replug the device and it will work. :-)

2
  • 1
    Hi, could you explain the steps to make this a useful answer (howto create the file and where).
    – NGRhodes
    Commented Jun 12, 2014 at 19:26
  • I did those steps, except using vi instead of emacs, and kept getting a black screen on reboot on 14.04. If you do do this, make sure you know how to login to the ctrl+alt+f2 terminal and move or remove this /etc/udev/rules.d/69-libmtp.rules file you're creating, which fixes the issue!! Unfortunately this answer doesn't work.
    – NoBugs
    Commented Aug 31, 2014 at 7:21
1

Plug the phone in, then reboot the phone while it's plugged in.

Worked for me using Ubuntu 13.10 and Lumia 520.

1
  • You mean that you didn't make any other action, just plug and play, right?
    – Braiam
    Commented Jan 19, 2014 at 3:40
1

Did you check with lock screen disabled? I remember earlier when I hadn't kept the password lock screen - the file browser used to show the device and I could access it. However, now that I have kept the password lock screen - the devices are visible but cannot be opened via file browser.

Of course there is one more additional thing: earlier I was using Ubuntu 12.04, now I use 14.04 - so I don't know if the issue is because of change of ubuntu version - I don't think so.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .