13

I downloaded the Linux drivers for my onboard RTL8111E (Mobo MSI B75 Pro3-M) from the Realtek site. The Realtek driver has been updated 23/09/2013, so I assume it can handle 64 bit Ubuntu (13.10 in my case). It seems to be compatible with kernel 3.xx.

I run autorun.sh as root but get the following error: “CONFIG_X86_X32 enabled but no binutils support”

I didn't expect this error, as my OS is 64 bit. Does anybody know how to fix this ?

Kind regards,

David.

23

I finally found the cause thanks to this link.

It seems that one shouldn't have spaces in the folder names (containing the driver of course) when building the driver. Replacing the spaces with underscores fixed the issue. I could build just like that. Strange... but it worked!

  • I didn't believe this comment... I was clearly proved wrong!... Thank you very much, it works! :D – Swordfish90 Nov 5 '13 at 23:04
1

Compiling drivers involves a kernel header make, which can fail with CONFIG_X86_X32 enabled but no binutils support if the kernel source directory belongs to root and you're running as an unprivileged user. Check in your make output to see if CONFIG_X86_X32 enabled but no binutils support appears in the kernel source directory, in which case try building the kernel sources (or your entire driver source) with sudo make.

Another common cause of CONFIG_X86_X32 enabled but no binutils support is spaces in the compilation directory as mentioned by David Van Huffel or binutils not installed as mentioned by chili555.

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post. - From Review – Thomas Dec 27 '18 at 11:27
  • @Thomas It does provide an answer to the question. Driver compilation involves a necessary kernel header compilation step, which will fail with CONFIG_X86_X32 enabled but no binutils support if the user does not have the correct permissions. Answer was maybe a little terse, I'll edit to make that more obvious. – Code Bling Dec 27 '18 at 19:54
0

It 'makes' for me on my 64-bit system without drama except for a notation about private key which may safely be ignored. Do you have binutils installed?

sudo dpkg -s binutils

If not, install it:

sudo apt-get install binutils

Then try again:

sudo -i
cd /home/<user_name>/r8168-8.037.00/
make clean
make
make install
exit
  • Many thanks for your help, I had high hopes. Unfortunately it didn't work. Binutils was already installed. The error “CONFIG_X86_X32 enabled but no binutils support” remains. I installed 13.04, thinking that might help, but that didn't change anything either. Any other suggestions ? – David Van Huffel Oct 30 '13 at 10:02
  • Are you compiling this exact same package? realtek.com.tw/Downloads/… That is, r8168-8.037.00? – chili555 Oct 30 '13 at 11:41
  • Indeed, that same one. – David Van Huffel Oct 30 '13 at 11:56
  • Can I enforce CONFIG_X86_X32=n somewhere ? – David Van Huffel Oct 30 '13 at 12:04
  • Is this in a virtual machine? Did you check here? translate.google.com/translate?hl=en&sl=pt&u=http://… See posts #7 and 8. Are you using install.sh or make and make install? – chili555 Oct 30 '13 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.