Ok, there are probably tons of questions asked related to myproblem but I'm in a delicate situation so I do not dare to experiment...


I have installed and setup a (Ubuntu/Windows7) dual boot on my corporate locked-down laptop, that is, first install Windows7 using a corporate netboot image, let it finish, then boot Ubuntu on a live USB and using gparted shrink the partition and install Ubuntu in a new partition along with a swap partition (Linux hibernate w:o swap partition wont really fly). Now this has to be done before checkpoint disk encryption is applied on the Windows7 partition.

Everything was fine, I run Ubuntu on daily basis and once in a while boot into Windows7 to do mundane corporate tasks, it usually works fine with hibernate/resume into Windows7.

This is irrelevant, but I need to get this rant of my chest

I also do hibernate/resume into Ubuntu and that works fine as well, except that sometimes the compiz window manager crashes and fails to be restarted, after a wake up from hibernate (I think it's an i915 driver issue according to google).

In such a moment, when compiz had crashed and I needed to finish some work, I quickly installed and tested a couple of window managers (twm, wmaker, XFCE-4) to be able to keep working without rebooting.

One of those FU**ING PIECE OF S**T packages found it amusing to change the grub splash to a DEBIAN F***ING S**TLOOKING SPLASH , "la la la, I'll just change the splash to make the world a better place and innocently run grub-update..." without ever F***ING ask me whether its okay to F*** around with my delicate but working dual boot environment (requires two Window7 boot attempts to get past the checkpoint disk encryption).

This is relevant

So on next reboot my option to run Windows7 on boot was gone, I tried grub-install, grub-update but it was not able to restore the Windows7 boot option. I can boot into Linux w:o problem, but the options to boot Windows7 is gone.

So I started googling and felt horror build up since every solution I found kept mentioning Windows7 repair CD, MBR restore, bla bla, NOT A F***ING OPTION IN A LOCKED DOWN CORPORATE BOOTIMAGE, I need to get it restored without a Windows7 repair CD or whatever.

Now I'm much more relieved since I managed to boot into Windows7 using the grub cli by running the following commands:

>chainloader (hd0,msdos1)+1

So my question is how to get that back into my Grub boot menu as the option to run Windows7?

The reason I'm asking how to do this is that I'm terrified to F**CK up and loose my ability to boot into Windows7, because restoring what I have (had) requires a lot of mundane work (which includes calling to the outsourced help desk across the globe just to re-enable a network boot image for my laptop).

1 Answer 1


Ok, I'm a bit more relaxed now since I believe I know why this happened. First, the follwing guide solved the actual problem of re-enabling Windows7

Manually adding an entry for Windows 7 to an Ubuntu GRUB2 menu

Then the reason for the boot menu to loose Window7 was that when /etc/grub.d/30_os-prober ran the first time, that was when I installed Ubuntu 12.04 direct after installing Windows7 but before checkpoint disk encryption was enabled, it correctly detected Windows7.

But now with checkpoint disk encryption active, grub fails to detect Windows7 and the boot option will not be added. As was the case when one of the packages executed update-grub after changing the grub splash.

As for which of the window managers that, as a side effect when being installed, ran update-grub2 and blew my current boot menu was xcfe4. Since it depends on desktop-base, which replaces/sets the grub splash with spacefun-grub.png and runs update-grub2.

So installing xcfe4 using apt-get install xcfe4 runs update-grub2 at one point!!!

This side effect has also made it into launchpad

  • You should accept your answer as the "solution", by clicking the check mark next to it. Thanks. Commented Feb 19, 2017 at 1:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .