So, I'm watching "The Walking Dead" and all of the sudden I lose control of my mouse through the touchpad. At first it was just for my user. I could reboot my system and switch to another user and use it just fine. I cannot explain the steps I took (I'm using the keyboard to manuver firefox right now) but it was something along the lines of:

sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps

After this command, I regained control of my mouse but the computer didn't recognize it as a touchpad. I thought if I rebooted again, it may do the trick. So after I rebooted, the mouse went completely kaput. I cannot get the mouse to work at all now even though I've tried the command several times. I've tried different users and it's still the same.

  • After "sudo apt-get update && sudo apt-get dist-upgrade && sudo reboot" mouse has been restored for other users but I'm still unable to use it.
    – KI4JGT
    Oct 29, 2013 at 6:29
  • did "sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps" again. I am able to use it but must enter the command every time I log in. The computer still doesn't see the touchpad as a touchpad.
    – KI4JGT
    Oct 29, 2013 at 6:36
  • can gpointing-device-settings see the touchpad?
    – Vreality
    Oct 29, 2013 at 6:37
  • xinput list has it listed as a "PS/2 Generic Mouse" I will add the results of gpointing-device-settings here when I have installed the program. gpointing-device-settings sees it "PS/2 Generic Mouse"
    – KI4JGT
    Oct 29, 2013 at 6:40
  • Something interesting in the dmesg? An usb mouse works ok?
    – Braiam
    Oct 31, 2013 at 20:46

3 Answers 3


This is a confirmed bug which affecting many other people: Bug #549727: Touchpad stops working after login. You can find in the bug comments some partial fixes, but, keep in mind, neither one is mutually agreed by everyone.

Ubuntu 13.04 will reach soon (in January) at its end of life. So you should consider to upgrade your system to 13.10 which came with a new kernel - 3.11, that could solve your problem.

Meanwhile, to solve the problem for now, first check if your touchpad is enabled. If is enabled, try to reinstall xserver-xorg-input-synaptics.If this will not work, change the module for your touchpad (but in this last case your touchpad scroll will be dead).

I. Check if your touchpad is enabled

Open dconf Editor, navigate to orggnomesettings-daemonperipheralstouchpad and make sure that tauchpad-enable is enabled/ticked (check also the other options):

enable touchpad

Check also from terminal with the following command:

synclient | grep Touchpad

If the output is different than:

TouchpadOff             = 0

then your touchpad is off and you should put it on using the following command:

synclient Touchpadoff=0

If the problem still persists, then go forward to the step II.

II. Reinstall xserver-xorg-input-synaptics

To reinstall xserver-xorg-input-synaptics package, run the following command in terminal:

sudo apt-get install --reinstall xserver-xorg-input-synaptics

After the reinstallation is finished, reboot your system. If the problem still persists, check again if your touchpad is enabled using dconf Editor, then go forward to the step III.

III. Change the module for your touchpad

If the previous solutions didn't work, do the following:

  1. Create a file called touchpad.conf in /etc/modprobe.d/ using the following command in terminal:

     sudo -i gedit /etc/modprobe.d/touchpad.conf
  2. Add the following line inside the touchpad.conf file just created:

     options psmouse proto=imps
  3. Save the file and close it.

  4. Reboot your system,

After reboot your touchpad should work normally.

  • It's working at startup now but it's still seen as ps/2 Generic Mouse and doesn't allow me to scroll as a touchpad.
    – KI4JGT
    Nov 1, 2013 at 0:31
  • @KI4JGT See this answer to enable the scrolling. Nov 1, 2013 at 8:12
  1. If the Touchpad was working earlier the way it should've, check whether (or not) it is enabled from the Keyboard. The key cmbination differs from model to model, for eg mine is Fn+F1. Check it from your laptop's user manual, or look for a function key that has a touchpad drawn on it; press this key with Fn key.

  2. If the problem wasn't that simple, try reinstalling your Kernel:

    Run the following command in a terminal (Ctrl+Alt+t):

    dpkg -l | grep linux-image-.*-generic

    Look for the kernel version you want to reinstall then run:

    sudo apt-get install --reinstall linux-image-3.X.Y-ZZ-generic

    Of course, you must type the real kernel version (e.g. linux-image-3.11.0-12-generic) instead of linux-image-3.X.Y-ZZ-generic.

  3. If that too fails, run synclient Touchpadoff=0 and check. (If it doesn't work after a reboot, just add this command to Startup Applications.)

  4. If even that doesn't solve a thing, let's create a configuration file for your touchpad:

    sudo -H gedit /etc/modprobe.d/touchpad.conf

    Add to the touchpad.conf file, and save:

    options psmouse proto=imps

    Reboot your system, the touchpad should now work.


Please try upgrading to Ubuntu 13.10 Saucy as the latest Kernel 3.11*** is known to fix this bug.

In Terminal, run:

sudo apt-get update
sudo apt-get do-release-upgrade
  • There is no reasonable reason to reinstall the kernel for this purpose. And also you should add a note of warning when you put someone to do this. Nov 1, 2013 at 12:39
  • @RaduRădeanu I misread in the comments that he has installed 13.10 "as soon as it was release(d)". My bad! I'll update. However, reinstalling the Kernel in 13.04 'may' still work as the touchpad was working fine until now.
    – TomKat
    Nov 1, 2013 at 12:49
  • after wasting a day on this thing installing and reinstalling the hell out of it, Fn + F5 did it. -_- Mar 1, 2016 at 18:14

Create a configuration file for the touchpad:

sudo -H gedit /etc/modprobe.d/touchpad.conf

Copy and then paste into the touchpad.conf file:

options psmouse proto=imps

SAVE file and reboot.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .