Even though Dropbox's app indicator dissapearing from the tray area seems like a recurrent enough problem, my issue is a litte different.

When I login, I can see the app panel populating, and the dropbox icon does indeed appear (config'd as startup application), but after some other icons show up (bluetooth, battery, etc.) it's gone. It's still running though.

I'm guessing it's having issues with staying pinned, and I don't know how to start addressing this problem.

I have tried many if not all solutions provided here in the forums for the "icon missing" questions.

So far:

  • I've whitelisted everything regarding panel

  • Uninstalled-reinstalled (with and without rebooting in between)

  • Overwritten current installation

  • Purged installation from terminal

  • Installed from Software Center, from .deb file (from dropbox website) and from terminal (commands listed on dropbox website)

  • batch deleted every "dropbox" ocurrences from terminal (files and folders) and reinstalled

  • Ran sudo apt-get install libappindicator1, it installed, but didn't solve anything

A very important fact is that it used to work, then out of nothing it stopped syncing (a corrupted file I think). I reinstalled dropbox and the applet started behaving as I described above.

I'm on Ubuntu 12.04 LTS - 64 bits.

Any insight would me much appreciated!

  • 1
    You can always answer your own question. Rather than putting the solution in the question, you should move it to an answer which you can then accept yourself. This is a Q&A site, not a forum. :)
    – chaskes
    Nov 10, 2013 at 1:57

3 Answers 3


I have never experienced the problem you describe with the Dropbox applet. However, since the introduction of indicator applets in Unity I have experienced several other buggy applets that did not display correctly and in some cases covered adjacent applets. I would suggest that you uninstall all non-standard applets to make sure this is not the case for you.


Have you considered installing Dropbox from dropbox.com using the Dropbox recommended way to install Dropbox in the user directory?


cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86" | tar xzf -


cd ~ && wget -O - "https://www.dropbox.com/download?plat=lnx.x86_64" | tar xzf -

Next, run the Dropbox daemon from the newly created .dropbox-dist folder.


Reference: https://www.dropbox.com/install?os=lnx


Found a solution!

I ended up installing the dropbox-tray package through Synaptic Package Manager from Lihis.net and installed new indicator icons icons. Worked like charm. Sadly I don't know what went wrong in the first place, since it used to work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .