12

I'm using Ubuntu 13.10, but I think the keyboard shortcut wasn't bound in 12.10, but could be wrong.

It's not in the shortcuts tab of keyboard settings. How can I change the Unicode input from Ctrl+Shift+U to other?

  • I'm pretty sure this is hard-coded in Gtk, similar to the compose table. – chaskes Oct 29 '13 at 19:53
  • what editor are you using? – chaskes Oct 29 '13 at 20:04
8

Control+Shift+u for unicode input is hard-coded into the GTK+3 default input method. (Source: GtkIMContext).

The easiest thing to do is probably to use a different set of keys for whatever functions you need.

But you have some other options for Gtk applications. Both involve replacing the default input method with no input method.

In gedit and in gnome-terminal, you can right-click the window and choose Input Methods >> None. This may be a good solution if you do not need an input method for other reasons and do not need the features of LibreOffice.

For LibreOffice, there does not appear to be a way to bypass the system input method. If you do not need an input method, you can turn it off system-wide by going to System Settings >> Language Support and setting Keyboard input method system to none. You must reboot for this to take effect. (Logging out was not enough.)

Note that this method is only hard-coded into Gtk applications. If you do not mind installing KDE dependencies, you can use an editor like kate and change the accelerators to suit your need.

  • what are the consequences of using "none" (besides ctrl+shif+u)? – Alex Oct 30 '13 at 0:23
  • 2
    @alex If you have to ask, then probably nothing you would notice. Input methods take keys in sequence and then output some other result. If you are not inserting unicode or special characters, I doubt you will notice it. – chaskes Oct 30 '13 at 0:29
  • For Brazilian people it will be a big mess, because Portuguese uses a lot of accents – deFreitas Jul 26 '18 at 22:30
  • @deFreitas Well, this question is really about changing how to insert a single unicode char. For typing in Portuguese, you would want to change the keyboard layout to a Portuguese layout or use the compose key. :) – chaskes Jul 27 '18 at 15:25
0

I was able to bypass this binding by unsetting 'XMODIFIERS' System variable just before launching my application (Intellij IDEA) to prevent toggle case keyset conflict.

export XMODIFIERS=""
myapp.sh

Tested on Ubuntu 18.10, libgtk-3-0 3.24.1-1ubuntu2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.