0

I tried to install Skype on my 12.04 LTS 64-bit install using the documentation here. Details are below, the TL;DR version is as follows:

  1. The Skype install (I think) borked a video driver and caused a crash.
  2. Somehow, the Skype install made Ubuntu think it was a 32 bit box, so when I tried to to "recover" after a restart, selecting the recovery boot option, and using the "fix installed packages" menu option, dpkg "helpfully" removed my 64 bit libraries/kernel and installed the 32 bit versions instead.
  3. Removing Skype didn't give me my 64 bit version back.

How do I get my 64 bit install back? Is this just a re-install at this point?

Details

I tried using the documentation here. For some reason, the line

sudo dpkg --add-architecture i386

didn't work. It complained:

dpkg: error: unknown option --add-architecture

Bravely, naively, I went on. These commands went just fine.

 sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
 sudo apt-get update && sudo apt-get install skype

I launched Skype. It worked. The audio test worked fine. The video wouldn't work. I did some more searching. I'm on a Lenovo Y510p and the camera detected as an EasyCam but it was just giving me a green rectangle instead of showing my video.

I found this answer, so I hit Fn-Esc. I also double clicked on the green rectangle.

Oh dear Lord was that a bad idea.

My screen went blank. Nothing was working. I used Ctrl-F1 to get to a terminal... a sea of error messages were pouring down -- I logged in (blindly!) and typed

 killall skype

The messages stopped. (I don't recall what they said.) I tried Ctrl-F7 back to X, but that X session was still black. I rebooted my box.

It hung on an error that said something about

 TDMS table invalid.

Not knowing what to do, I rebooted, went selected the rescue option from the boot loader, and tried to "repair installed packages".

What happened next was really weird: It installed the i386 kernel, even though this is a 64 bit box.

The 32 bit kernel booted okay. I removed skype via

 apt-get remove skype
 apt-get autoremove

But I can't get my 64 bit kernel back. How do I do that?

0

The best way to do this would be to reinstall Ubuntu. Sorry.

If you are REALLY brave, you can reinstall all your packages with the x64 version, but that would just take way too long and there's no guarantee that it would work.

Similar thread: How can I switch a 32-bit installation to a 64-bit one?

  • Thanks for the pointer to the other question. I had tried to search for something along those lines, but I could not find it. I'll go with the reinstall. Boo. – Nathan VanHoudnos Oct 30 '13 at 0:44
  • I wish you luck in your endeavors. – Kaz Wolfe Oct 30 '13 at 2:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.