Since I installed Ubuntu 13.10 my mouse cursor has been disappearing every second time i boot Ubuntu 13.10. So the way I solve it is by restarting Ubuntu, and the mouse cursor will become visible again. If I would then want to make a restart again, the cursor will be gone until a restart has been done. So to sum up - every second boot will show a cursor, and the other will not.

Now of course I can keep on doing like this, but it is VERY annoying. So i would ask if there was a way of solving this. Please do not hesitate to ask me for more information about my system if needed.


You can check this bug


I'm no longer affected on a new 14.04 dev install but on my 13.10 install from 2 weeks prior to release it still could happen

For the 13.10 install disabling the gnome-settings-daemon cursor plugin has proved effective. To try, in terminal

gsettings set org.gnome.settings-daemon.plugins.cursor active false

To re-enable just run same command but use true instead of false

  • Thank you doug I have restarted my system a couple of times now, and the cursor has been visible all the times for now. For now, all I can say is that this solution works for me. Thank you!
    – sleort
    Oct 28 '13 at 20:38
  • I'm affected by this in Ubuntu 14.04 and this workaround didn't work for me :-(
    – knocte
    May 14 '14 at 17:27

settings - displays - disable unknown display. it works for me

  • this has worked for me beautifully (don't forget to click on "Apply" after disabling the display, instead of just closing the dialog)
    – knocte
    Aug 12 '14 at 1:02
  • Does this option exist in 14.04? I'm looking at the Displays dialog but am not seeing any way to disable unknown displays.
    – Brian Z
    Sep 23 '14 at 3:15

I have this issue happen randomly on Ubuntu Gnome 15.04 (sometime at boot time, sometime while the system is up): the mouse cursor doesn't show up but the mouse can still be used. One way to make it reappear that worked for me, is to change the resolution back and forth. Kinda hard without seeing the mouse but I have a touchscreen so that's a little easier.

  • I just had the problem on 15.10 on two computers at a time, a reboot fixed one computer and on the other I just restarted X11 a couple of times and got the mouse back... Mar 21 '16 at 0:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.