6

Hi I'm a complete newbie to linux. I am running ubuntu 13.04. I am trying to install a canon pixma mp495 wireless printer. I have downloaded the canon printer driver from the canon european site but cannot install the driver. Can anybody help?

2
  • Try here: http://www.canon.co.uk/Support/.... Canon printers will work with Linux, but Brother or HP printers generally work better. You may also need to install CUPS (was/is known as Common Unix Printing System). Have you got it working with any other printers?
    – Wilf
    Oct 28, 2013 at 19:23
  • I presume that you have downloaded a tar.gz driver. You will probably have to extract the file, and look for any files called README or INSTALL. Open them in a text editor e.g. gedit, and see if there are any installtion instructions.
    – Wilf
    Oct 28, 2013 at 19:38

4 Answers 4

2

Have the printer connected and on the same Wi-Fi network as the computer.

Go to System Settings, Printers, and add it. It should show up, and walk you through getting drivers and naming it.

In Linux, you rarely need to get software of any kind from Google searches. This is a common mistake of those coming from Windows. Programs come from repositories, and drivers are no different.

1
  • My system is Cinnamon 5.2.7 Linux Mint 20.3 Una base: Ubuntu 20.04 focal. I am trying to add a printer via system settings. At the device choice, I have Generic CUPS-BRF and Network printer. At both options, I can find my Canon MP495. None of them run the printer. Which option is proper for WIFI?
    – Antoni
    May 22 at 8:52
2

To install Canon Pixma mp495 printer driver for linux ubuntu 10.04 you need to add PPA below in your ubuntu system.

First open Terminal Ctrl+Alt+T then enter:

sudo add-apt-repository ppa:michael-gruz/canon

For Ubuntu 14.04:

sudo add-apt-repository ppa:inameiname/stable

Then enter:

sudo apt-get update

Disconnect your Canon MP495 from your computer or turn it off. Then, install the Canon MP495 driver with the following command.

sudo apt-get install cnijfilter-mp490series
1
  • It fails for Ubuntu 20.04 focal. The result of sudo add-apt-repository is Can't add a private package archive: "This PPA doesn't support focal"
    – Antoni
    May 22 at 8:21
0

i tried to install "sudo apt-get install cnijfilter-mp490series" but got

"No-Aspire-V3-551 ~ # sudo apt-get install cnijfilter-mp490series Reading package lists... Done Building dependency tree
Reading state information... Done E: Unable to locate package cnijfilter-mp490series"

should I look for another repo?

1
  • This is not an answer. I understand the rules for a required number of reputation to comment are a bit annoying, but to keep the site clean they need to be enforced. If this is different enough from the problem the OP has you can ask a new question and have it dealt with there.
    – sbergeron
    Dec 1, 2015 at 1:17
0

I have succeeded in scanning over USB using the Canon Pixma MP 495 printer/scanner on Kubuntu 16.04. I just followed this guide:

SANE - Installing a scanner that isn't auto-detected - Community Help Wiki

Previously I had tried Warwizard's solution but that didn't seem to help the scanner. Now the Skanlite app still crashes but XSane Image works perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.