3

I figured out how to add

set -g prefix ^B

to .byobu/profile.tmux

I typed the same command at the tmux : line and indeed ^B is now my prefix character, but ^A is also still my prefix character. I'd like to unbind it. I've tried unbind ^A at the : prompt. I've tried unbind-key ^A and unbind C-a and unbind-key C-a and none of them work.

How can I unbind ^A without restarting my tmux session?

5

Easy answer which took me 1 day to find: run byobu-ctrl-a

$ byobu-ctrl-a

It asks what ctrl-a should do and the change is immediate.

I found I could also pass argument to it, such as "emacs" meaning, don't let tmux use it.

$ byobu-ctrl-a emacs

It turns out all this script does is ask the currently running tmux to source its config again from beginning. I could have done this manually by ^B:source-file /usr/share/byobu/profiles/tmuxrx

That system byobu file sources my local user config for byobu-tmux, so my key change took effect.

  • This helped me. Thanks. In my situation i had tmux use C-s as the prefix but thanks to this byobu was also using C-a as the prefix. – Karthik T Aug 15 '17 at 7:10
0
  1. Launch byobu-config directly or with F9 shortcut

    byobu config screenshot

  2. Select your character

    escape squence

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.