3

I'm really sorry for posting this. I know it may have been asked a thousand times. I have googled like crazy and I'm on the verge of desperation here.

Basically, I followed this guide:

http://motionsoundfx.com/2012/05/ubuntu-vnc-afp-macosx/

To create a small personal file server. When I installed it, I was able to connect to it just fine, I connected with my Ubuntu username and password and I was able to see the home directory. But later, I had to restart the file server so I could prepare a couple of other hard drives to put in.

When the server restarted, I tried to connect to it, but I got an error message on my Mac:

"The version of the server you're trying to connect to is not supported. Please contact your system administrator to solve this problem."

Again, I have googled like crazy for this, and everybody says it is a problem with OS X Lion and up (assuming it affects Mavericks too). I have tried all the fixes mentioned for Lion and Mountain Lion and I haven't had any luck. That's the reason I'm posting this here: I suspect the problem is with my Ubuntu server. This happened after I restarted the server. Before restarting the server, I just put in my credentials and saw my home directory. Something when I restarted the server must have been messed up.

I have found some other solutions, including to use "SHX2" in the conf file, but it hasn't worked for me.

I ask for your help to solve this issue.

Also please understand I'm completely illiterate when it comes to Linux. This is a nice chance to me to learn the OS so please give me detailed steps to do things if you deem it necessary. Thank you!

I'm using Ubuntu Server 13.10 (the latest one as of today).

2

This worked for me on Fedora 20.

  • Edit /etc/netatalk/afpd.conf. At the end of the file are the default parameters:

    -tcp -noddp -uamlist uams_dhx.so,uams_dhx2.so
    

    Notice it is commented out. Uncomment the line and change it to:

    -tcp -noddp -uamlist uams_dhx_passwd.so,uams_dhx2_passwd.so
    
  • I don't know if the leading space is important,so leave it in. Restart netatalk:

    systemctl stop netatalk
    

    Wait for about 20 seconds or so.

    systemctl start netatalk
    
  • Adjust path names and restart commands for Ubuntu. It should work.

| improve this answer | |
0

In the end, I could never get Netatalk to work with OS X Mavericks. With AFP being deprecated and all, I decided to setup my file server using SMB instead.

It worked wonderfully. Here's the tutorial I wrote:

http://www.andyibanez.com/260-linux-file-server-os-x-mavericks

DISCLAIMER: While I am the author of that article, I really want people to find it helpful. Please don't take this as personal advertising. Thank you!

| improve this answer | |
  • so, what about Time Machine backups? Is it possible to setup TM backup trough smb? – skywinder Dec 14 '13 at 13:55
  • To be honest I have no idea, as I don't use my server as a Time Machine backup, but if it was possible with AFP, I don't see why it would be any different with SMB. – Andy Ibanez Dec 14 '13 at 17:35
0

This solution worked for me (and enabled Time Machine) for Mavericks -> Ubuntu.

===================  
BEGIN WORKAROUND  
===================  
# cd /usr/lib/netatalk  
# mv uams_dhx2.so uams_dhx2.so.broken  
# ln -s uams_dhx2_passwd.so uams_dhx2.so  

Sourced from this link via this one. Oh yeah, you'll need to restart netatalk after that change...

Good luck :-)

| improve this answer | |
0

On OSX 10.9.5

For me setting /etc/netatalk/afpd.conf to the following solved above error for me.

- -transall -uamlist uams_dhx2_passwd.so -nosavepassword -noddp
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.