My password contains a # symbol in it, and recently I've found that if I lock my screen and come back I won't be able to log in, forcing me to shut down the computer and try again. After one of these reboots and successfully logging in, I then tried installing something in terminal, which required me to enter my password. When I tried to install it though, I kept getting told that my password was wrong. Just out of curiosity I tried writing my password where I could see it, and sure enough instead of a #, there was a \ instead.

On an UK keyboard the button above the right shift, next to the backspace/enter button, is #, and shift+3 is the GBP symbol. But now it seems to have changed to an US layout, where shift+3 is #, and the # key is . My password is pretty long and this bug is really getting irritating, because it makes me stop and press in each key individually, which makes it take much longer to do anything. Also I need to do quite a bit of word processing as well as HTML coding, and all sorts of keys seem to have been changed, which is obviously going to be a hindrance.


This seems to be a common problem since Ubuntu 13.10.

What you need to do is restart lightdm by doing the following.

Open Terminal, copy and paste the following and press enter:

sudo restart lightdm

Your keyboard will now be reset to United Kingdom

  • Thanks! This worked like a charm, and even helped with another problem I was having, where my time and date panel at the top went missing, and all the options to bring it back in the settings were greyed out. – Adam Oct 28 '13 at 11:23
  • 1
    I had the power/shutdown button go missing once, hopefully there will be an update to fix it once and for all. Glad I could help. – scouser73 Oct 28 '13 at 11:33
  • Also, I just found that changing the keyboard layout with the little "En" box at the top of the screen to US and back to UK again works. Hopefully they can find a permanent solution to this soon. – Adam Oct 28 '13 at 11:34
  • There is a bug in ubuntu which probably relates to this. bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/… – kmpm Jan 17 '14 at 18:01
  • 1
    Yes it worked but you should warn us that it would restart our computer and kill anything running without warning – CashCow Jan 25 '15 at 12:35

This should permanently fix the problem in 13.10 and 14.04:

In the ubuntu software center, install "dconf Editor" (dconf-editor) (if you don't already have it). Open it, then open desktop -> ibus -> general. Now enable the property "use-system-keyboard-layout". (You want it to have a checkmark next to it.)

Source: https://bugs.launchpad.net/ubuntu/+source/indicator-keyboard/+bug/1240198

  • Thank you, this reslolved the issue without having to reboot the system. – Kayote Dec 18 '15 at 10:30

Im still seeing this problem, and its been four months.

I did not see this issue until recently, so Im unsure what has triggered it.

My temporary workaround is to have the Text Entry indicator visible on the taskbar (All Settings>Text Entry>"Show current input source in the menu bar" checked), keep both UK and US keyboards installed, then when I see the bug, switch to US, then back to UK

Am also hoping for a permanent fix soon!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.