10

I upgraded from 13.04 to 13.10 and now all icons in the application lens are gone.

Screenshot of missing applications in Unity 13.10 application lens

This is what I tried so far:

  • apt-get install --reinstall unity-lens-applications
  • unity --replace and unity --reset-icons
  • moving ~/.config to ~/.config2
  • deleting ~/.cache/software-center and ~/.cache/unity

Most of these things have been suggested in this question: Unity Applications lens is empty - but all to no avail.

10

I think this is likely because the unity-scope-home package is not installed.

Try using Software Center to find and install that package, log out and back in to restart Unity, and see if that resolves the problem.

  • 2
    Ran apt-get install unity-scope-home and all items are back again :) Thank you! – Michael Osl Nov 4 '13 at 9:41
-1

I think I may have had a similar problem, not sure it was due to upgrading to 13.10 or due to user error. I ended up fixing it as follows:

  1. Log out of unity and log in to tty1 (ctrl-alt-f1).
  2. "sudo apt-get purge unity" (gets rid of unity and it's settings).
  3. "sudo apt-get autoremove" (gets rid of any leftover packages that unity depended on, like the lenses and such.)
  4. "sudo reboot" and log into tty1 again afterwards.
  5. "sudo apt-get install unity"

Bit drastic, but it worked.

  • This knocked the life out of Ubuntu. – Tony Lancer Nov 16 '15 at 16:27

Not the answer you're looking for? Browse other questions tagged or ask your own question.