0

I've installed the ax88179 package from the PPA (since the ax88179 driver isn't in the 3.8 kernel). But now I'd like to install kernel 3.11.6 and this module is already included here. So I'd like to uninstall the the module from the package but this fails with the following error message

The following packages will be REMOVED:
ax88179*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 313 kB disk space will be freed.
Do you want to continue [Y/n]? 
(Reading database ... 202833 files and directories currently installed.)
Removing ax88179 ...
Error! There are no instances of module: ax88179_178a
1.6.0 located in the DKMS tree.
rm: cannot remove ‘/usr/src/AX88179_178A_LINUX_DRIVER_v1.6.0_SOURCE’: 
No such file or directory dpkg: error processing ax88179 (--purge):
subprocess installed pre-removal script returned error exit status 1
No apport report written because MaxReports is reached already

ln: failed to create symbolic link ‘/usr/src/AX88179_178A_LINUX_DRIVER_v1.7.0_SOURCE’: File exists
Error! DKMS tree already contains: ax88179_178a-1.7.0
You cannot add the same module/version combo more than once.
Module ax88179_178a/1.7.0 already built for kernel 3.8.0-32-generic/4
Module ax88179_178a/1.7.0 already installed on kernel 3.8.0-32-generic/x86_64
Errors were encountered while processing:
 ax88179
E: Sub-process /usr/bin/dpkg returned an error code (1)

It complains about both version 1.6 and 1.7. I've updated to 1.7 a couple of days ago. --force doesn't help either. I just want to get rid of it since when I'm running 3.11.6 the versions interfere with each other.

1

I've partially solved this, at least so that the installed kernels doesn't use the DKMS module anymore. I still can't remove the package but that doesn't matter anymore, at least I've remove the DKMS module.

I remove the module by issuing sudo dkms remove -m ax88179_178a -v 1.7.0 --all and the module was removed from all installed kernels.

0

Try to update to the latest version and then remove it. 1.7 is quite old (the latest one is the 1.12) and as I remember it had some install/upgrade is sues. If you don't use the repository anymore, you still will be able to download the latest version from the PPA page directly: https://launchpad.net/~qji/+archive/ubuntu/ax88179/+packages

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.