I am new to Ubuntu (from Windows). I tried installing Foxit Reader via Wine, the setup runs, but its more like just a splash screen then Foxit is open. When I try to open another PDF by double clicking, it says "File not found". Under Applications > Wine > Programs theres not Foxit. Have foxit installed incorrectly?


It appears that FoxIt have designed the windows version to act like its "portable" version if it detects the "setup.exe" running under Wine.

This means that it doesnt need to be 'installed'. You can create a Launcher if you

  • Right-click on your desktop.
  • In the Command Line entry Browse to where the setup.exe was downloaded.
  • Then amend the entry to look like the following: enter image description here

Similarly (if using Lucid or Maverick),

  • right-click the menu in the top panel and choose the option "edit menu".
  • Locate where you want to locate the new menu option and create the new menu option using the same Command Line entry as in the screen-shot.

If you want to use the Windows Foxit Reader automatically when you double click a .pdf file then the instructions are very similar:

  • Right click the PDF and choose the option "Open with other application"
  • Use the Command Line syntax as above but append \"z:%f\" i.e. it should look like: enter image description here

Remember to leave the check box "Remember this application.." ticked

  • No, I think u misunderstood me, I was asking my cant I associate say *.pdf to Foxit, I seem to always get File not found, I think I saw somewhere its because Foxit expect Windows style filenames "\`" but Ubuntu gives Linux style "/`"? – Jiew Meng Apr 26 '11 at 14:10
  • ok - I've amended my original answer. – fossfreedom Apr 26 '11 at 15:47
  • @fossfreedom, cool! but what does that snippet actually do? – Jiew Meng Apr 28 '11 at 13:23
  • 2
    The Z:%f fools Foxit Reader so that it thinks that it is loading the file being passed as a parameter from the z:\ drive. In wine, Z:\ is mapped to your file-system. – fossfreedom Apr 28 '11 at 13:27
  • @fossfreedom, I now used Ubuntu Minimal + LXDE. I tried the same thing but nothing happens theres no errors either ... any ideas how I can troubleshoot? – Jiew Meng May 29 '11 at 12:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.