3

I'm using two Monitors, a Belinea o.display 1 (Recognized as a Rogen Tech Distribution Inc 20" by Ubuntu, but working fine) on the DVI-Output (connected via DVI-to-VGA-adapter) as my primary Monitor and a Dell 19" (Recognized correctly) on the HDMI-output (via HDMI-to-DVI adapter) as secondary monitor. The graphics controller is a GeForce 9500 GS. I'm running a fully updated Ubuntu 13.04 with nouveau 1:1.0.7-0ubuntu1.

The problem is that the second monitor (Dell) never seems to come out of standby during boot: the screen stays black and the status led on the monitor stays orange (it's green when it's on). It is correctly recognized an the size of the desktop is set accordingly, it just stays black. Changing any setting via xrandr/arandr/etc. does nothing. The on-screen-menu of the monitor reports it to be in power save mode.

When using the proprietary NVIDIA-Drivers, the second monitor works just find. But these drivers cause a lot of other problems on my system, so i would really like to avoid them.

On Ubuntu 12.10 i had found a workaround: When moving the relative position of the second monitor slightly down and the up again, it would turn on and function normally:

xrandr --output DVI-I-1 --mode 1680x1050 --pos 1280x0 --rotate normal --output HDMI-1 --mode 1280x1024 --pos 0x88 --rotate normal
sleep 2
xrandr --output DVI-I-1 --mode 1680x1050 --pos 1280x0 --rotate normal --output HDMI-1 --mode 1280x1024 --pos 0x0 --rotate normal

This workaround stop working after the update to 13.04, and now i'm looking for a new solution.

Has anyone experienced something similarity?

xrandr output:

Screen 0: minimum 320 x 200, current 2960 x 1050, maximum 8192 x 8192
DVI-I-1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 433mm x 270mm
   1680x1050      60.0*+
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     72.0     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
HDMI-1 connected 1280x1024+1680+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0*+   75.0  
   1152x864       75.0  
   1024x768       75.1     60.0  
   800x600        75.0     60.3  
   640x480        75.0     60.0  
   720x400        70.1  

lshw -c video:


  *-display
Beschreibung: VGA compatible controller Produkt: G96 [GeForce 9500 GS] Hersteller: NVIDIA Corporation Physische ID: 0 Bus-Informationen: pci@0000:01:00.0 Version: a1 Breite: 64 bits Takt: 33MHz Fähigkeiten: pm msi pciexpress vga_controller bus_master cap_list rom Konfiguration: driver=nouveau latency=0 Ressourcen: irq:16 memory:fa000000-faffffff memory:d0000000-dfffffff memory:f8000000-f9ffffff ioport:df00(Größe=128) memory:fb000000-fb07ffff

Thanks for your help!

1
  • Late I know.. but I have this same problem. All my open windows get squashed onto the laptop (primary) screen and my multi-desktop switching is screwed. Dec 9, 2013 at 17:39

3 Answers 3

5

I found a workaround for a similar problem. After boot, or X restart, one of my monitors goes into powersave, the other works fine. If I switch to a text only console (ctrl-alt-f1) the screen will turn on and work correctly. When I switch back to X (ctrl-alt-f7), my display will stay on. I think it is a frequency sync issue.

1
  • 1
    I wonder if it is possible to execute a command that does precisely the task of forcing the monitor to redraw or refresh or resync or whatever switching to and from console does. Sep 7, 2016 at 17:42
2

I'm having the same problem with Lubuntu 12.04. Your workaround with the pos argument does not work for me. What works for me is calling xrandr twice, with different resolutions:

DISPLAY=:0 xrandr --output HDMI1 --mode 1024x768
DISPLAY=:0 xrandr --output HDMI1 --auto

It's causing some ugly flickering, but does its job. And it saves me two keystrokes compared to Jeffery Williams solution, which also works for me.

0
0

I know this is old question. But I want to add my workaround here for the people that reach this question via Google search.

My problem span already Ubuntu 16.04, 18.04 and 20.04 I have a Dell laptop and Dell external screen.

My second screen goes directly into power saving mode after boot and stays in power savings mode.

The cause of this is. Every time I plug out the HDMI cable mid shutdown, this problem happen. So if I don't want to see this bug I need to wait till the shutdown is finished and then plug out the HDMI cable.

If I forget the cause above and plugged out the HDMI cable mid shutdown. I follow the following workaround to fix the problem.

  1. I shutdown the laptop and remove the HDMI cable from the laptop.
  2. After shutdown I remove the battery of the laptop for a few seconds. (Not sure what I am going to do if I buy a new laptop that I can't remove the battery)
  3. Then I boot up my laptop with the HDMI cable still disconnected.
  4. If the Ubuntu is up and running I put in the HDMI cable then it works again.

Hope the above helps somebody

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.