5

Ever since installing 13.10 (x64) every time I insert a USB flash drive, it mounts as read-only.

I tried using three different drives, and they all get mounted read-only. They were working fine on 13.04 and they still work fine in Windows, so I'm sure there is nothing wrong with the usb drive. How can I stop them from mounting as read only and make them writable?

  • Maybe your system is set to automount usb as ro. Show us your /etc/fstab file. – david tooke Jul 21 '14 at 17:34
1

This may not answer the problem in the question, but this question is one of the top search results for "ubuntu usb stick mounting read-only". If you're stumbling across this question in your search for answers, hopefully the following helps. This is what solved my own problem.

It's possible your USB stick(s) may in fact be corrupted. Assuming the stick uses the FAT file system, follow this guide.

How to fix read only USB pen drive in Ubuntu

Summary:

  1. Identify the mounted USB drive by running df -Th.
    • Example output: Filesystem Type Size Used Avail Use% Mounted on /dev/sda5 ext4 28G 25G 1.3G 96% / udev devtmpfs 2.0G 4.0K 2.0G 1% /dev tmpfs tmpfs 796M 1.1M 795M 1% /run .... /dev/sdd1 vfat 15G 12G 3.6G 77% /media/linux/C38C-099C
  2. Unmount the affected drive using sudo umount <mount path>.
    • Example: sudo umount /media/linux/C38C-099C
  3. Repair the drive by running sudo dosfsck -a <filesystem path>.
    • Example: sudo dosfsck -a /dev/sdd1.
  4. Safely remove the USB stick and reinsert.
0

The usb drives might be formatted ntfs, in which case you should install ntfs-3g.

  • Err, nope, it could be just that the filesystem is damaged and USB drives are normally formatted in FAT32 and ubuntu includes ntfs-3g by default. – Braiam Oct 27 '13 at 20:54
  • 1
    The drives are mounted FAT, not NTFS. I have tried reformatting them as well, but no change. They always get mounted read only. – osarusan Oct 28 '13 at 20:51
0

I'm taking a shot in the dark, but this may be related to: Unable to mount Windows (NTFS) filesystem due to hibernation. I've not had the problem with using flash drives, but I've sure had it with partitions. Sorry if it isn't relevant.

  • I've had that issue with NTFS drives too, but these flash drives are not NTFS so it doesn't apply here. – osarusan Oct 28 '13 at 21:00
0

It is likely that the USB drive is being mounted as ready only because of permission restrictions. One workaround to this is to run the file manager as root. To do so, open a terminal and, if you are using Ubuntu's native file manager (Nautilus), issue the command:

sudo nautilus

You will be required to type the root password to make the command work. This may allow you to write the USB, despite any permissions restrictions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.